]> git.pld-linux.org Git - packages/apache1-mod_frontpage.git/blobdiff - apache1-mod_frontpage.spec
- use "%(%{apxs} -q SYSCONFDIR)" for _sysconfdir definition
[packages/apache1-mod_frontpage.git] / apache1-mod_frontpage.spec
index 66e8e898c5c9079b2d98114ff5a05f59e53ad957..6e6fe3f01fa535f6b2ecd062ca594a809b224242 100644 (file)
@@ -1,36 +1,34 @@
 %define        mod_name        frontpage
-%define                arname          mod_%{mod_name}
-%define         apxs            /usr/sbin/apxs
-
-Summary:       The improved mod_frontpage module for the Apache Web server.
-Name:          apache-mod_%{mod_name}
-Version:       1.6.1
-Release:       0.1
+%define                apxs            /usr/sbin/apxs1
+Summary:       The improved mod_frontpage module for the Apache Web server
+Summary(pl):   Ulepszony modu³ mod_frontpage dla serwera Apache
+Name:          apache1-mod_%{mod_name}
+Version:       1.6.2
+Release:       1
+License:       Apache
 Group:         Networking/Daemons
-URL:           http://home.edo.uni-dortmund.de/~chripo/
-#Source0: http://home.edo.uni-dortmund.de/~chripo/download/%{name}-%{version}mdk-1.3.19.tar.bz2
-#The patch is now maintained by FreeBSD
-Source0:       http://people.freebsd.org/~mbr/distfiles/mod_frontpage-%{version}.tar.bz2
-Patch0:                mod_frontpage-PLD.patch
-Patch1:                mod_frontpage-Makefile.patch
-License:       Apache License
-Prereq:                grep
-Prereq:                apache(EAPI)  >= 1.3.23
-Prereq:                %{_sbindir}/apxs
-Requires:      apache
-BuildRequires: apache(EAPI)-devel >= 1.3.23
-BuildRequires: perl
+Source0:       http://dl.sourceforge.net/mirfak/mod_%{mod_name}_mirfak-%{version}.tar.bz2
+# Source0-md5: f7480918382067ce16e7afc40a633be4
+Source1:       %{name}.pl
+Patch0:                %{name}-mirfak.patch
+URL:           http://mirfak.sourceforge.net/
+BuildRequires: apache1-devel >= 1.3.23
+BuildRequires: %{__perl}
+PreReq:                apache1 >= 1.3.23
+Requires(post,preun):  %{apxs}
+Requires:      apache1
+Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
-%define         _sysconfdir     /etc/httpd
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
 
 %description
 This is a module for the Apache HTTP Server
 <http://www.apache.org/httpd.html>. It replaces the Apache-FP patches
 and module supplied with the FrontPage Server Extensions available
-from Microsoft <http://www.microsoft.com> and Ready-to-Run Software
-<http://www.rtr.com/fpsupport>.
+from Microsoft <http://www.microsoft.com/> and Ready-to-Run Software
+<http://www.rtr.com/fpsupport/>.
 
 Using this module allows you to use advanced features of the FrontPage
 client with your Apache HTTP Server (e.g. creating FrontPage-extended
@@ -38,43 +36,51 @@ subwebs using the FrontPage client in contrast to creating them as
 user "root" with "fpinstall.sh" or the "fpsrvadm.exe"-utility on the
 system's shell).
 
+%description -l pl
+To jest modu³ dla serwera HTTP Apache. Zastêpuje ³aty Apache-FP oraz
+modu³ dodawany do FrontPage Server Extensions dostêpnych od Microsoftu
+i Ready-to-Run Software (<http://www.rtr.com/fpsupport/>).
+
+U¿ycie tego modu³u pozwala na u¿ywanie zaawansowanych mo¿liwo¶ci
+klienta FrontPage z serwerem Apache (np. tworzenie podstron z
+rozszerzeniami FrontPage przy u¿yciu klienta FrontPage zamiast przez
+uruchamiania fpinstall.sh lub fpsrvadm.exe z pow³oki systemowej).
+
 %prep
-%setup -q -n %{arname}-%{version}
-%patch -p0
-%patch1 -p0
+%setup -q -n mod_%{mod_name}_mirfak-%{version}
+%patch0 -p1
 
 %build
-perl Makefile.PL
-%{__make} CFLAGS="%{rpmcflags} -DLINUX=22 -DINET6 -Dss_family=__ss_family -Dss_len=__ss_len -DDEV_RANDOM=/dev/random -DEAPI -DEAPI_MM"
+%{__perl} %{SOURCE1}
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sbindir}}
+
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 install fp{exec,static} $RPM_BUILD_ROOT%{_sbindir}
 
-gzip -9nf {CHANGES,FEATURES,INSTALL,LICENSE,README}
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-        /etc/rc.d/init.d/httpd restart 1>&2
+%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 fi
 
 %preun
-       if [ "$1" = "0" ]; then
-               %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-        if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-        fi
+if [ "$1" = "0" ]; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
+       fi
 fi
 
 %files
 %defattr(644,root,root,755)
+%doc *.html CHANGES FEATURES README
 %attr(755,root,root) %{_pkglibdir}/*
-%attr(4550,root,root) %{_sbindir}/fpexec
-%attr(0555,root,root) %{_sbindir}/fpstatic
-%doc *.gz
-
-%clean
-rm -rf $RPM_BUILD_ROOT
+%attr(4750,root,root) %{_sbindir}/fpexec
+%attr(755,root,root) %{_sbindir}/fpstatic
This page took 0.414897 seconds and 4 git commands to generate.