]> git.pld-linux.org Git - packages/apache1-mod_frontpage.git/blob - apache1-mod_frontpage.spec
- release 2 - license fix, new doc
[packages/apache1-mod_frontpage.git] / apache1-mod_frontpage.spec
1 %define         mod_name        frontpage
2 %define         arname          mod_%{mod_name}
3 %define         apxs            /usr/sbin/apxs
4
5 Summary:        The improved mod_frontpage module for the Apache Web server
6 Summary(pl):    Ulepszony modu³ mod_frontpage dla serwera Apache
7 Name:           apache-mod_%{mod_name}
8 Version:        1.6.1
9 Release:        2
10 License:        Apache
11 Group:          Networking/Daemons
12 #Source0: http://home.edo.uni-dortmund.de/~chripo/download/%{name}-%{version}mdk-1.3.19.tar.bz2
13 #The patch is now maintained by FreeBSD
14 Source0:        http://people.freebsd.org/~mbr/distfiles/mod_frontpage-%{version}.tar.bz2
15 Patch0:         %{arname}-PLD.patch
16 Patch1:         %{arname}-Makefile.patch
17 Patch2:         %{arname}-fpexec-PLD.patch
18 URL:            http://home.edo.uni-dortmund.de/~chripo/
19 Prereq:         apache(EAPI)  >= 1.3.23
20 Prereq:         %{apxs}
21 Requires:       apache
22 BuildRequires:  apache(EAPI)-devel >= 1.3.23
23 BuildRequires:  perl
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25 Obsoletes:      mod_frontpage
26
27 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
28 %define         _sysconfdir     /etc/httpd
29
30 %description
31 This is a module for the Apache HTTP Server
32 <http://www.apache.org/httpd.html>. It replaces the Apache-FP patches
33 and module supplied with the FrontPage Server Extensions available
34 from Microsoft <http://www.microsoft.com/> and Ready-to-Run Software
35 <http://www.rtr.com/fpsupport/>.
36
37 Using this module allows you to use advanced features of the FrontPage
38 client with your Apache HTTP Server (e.g. creating FrontPage-extended
39 subwebs using the FrontPage client in contrast to creating them as
40 user "root" with "fpinstall.sh" or the "fpsrvadm.exe"-utility on the
41 system's shell).
42
43 %description -l pl
44 To jest modu³ dla serwera HTTP Apache. Zastêpuje ³aty Apache-FP oraz
45 modu³ dodawany do FrontPage Server Extensions dostêpnych od Microsoftu
46 i Ready-to-Run Software (<http://www.rtr.com/fpsupport/>).
47
48 U¿ycie tego modu³u pozwala na u¿ywanie zaawansowanych mo¿liwo¶ci
49 klienta FrontPage z serwerem Apache (np. tworzenie podstron z
50 rozszerzeniami FrontPage przy u¿yciu klienta FrontPage zamiast przez
51 uruchamiania fpinstall.sh lub fpsrvadm.exe z pow³oki systemowej).
52
53 %prep
54 %setup -q -n %{arname}-%{version}
55 %patch -p0
56 %patch1 -p0
57 %patch2 -p0
58
59 %build
60 perl Makefile.PL
61 %{__make} CFLAGS="%{rpmcflags} -DLINUX=22 -DINET6 -Dss_family=__ss_family -Dss_len=__ss_len -DDEV_RANDOM=/dev/random -DEAPI -DEAPI_MM"
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sbindir}}
66
67 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
68 install fp{exec,static} $RPM_BUILD_ROOT%{_sbindir}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
75 if [ -f /var/lock/subsys/httpd ]; then
76         /etc/rc.d/init.d/httpd restart 1>&2
77 fi
78
79 %preun
80 if [ "$1" = "0" ]; then
81         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
82         if [ -f /var/lock/subsys/httpd ]; then
83                 /etc/rc.d/init.d/httpd restart 1>&2
84         fi
85 fi
86
87 %files
88 %defattr(644,root,root,755)
89 %doc CHANGES FEATURES LICENSE README
90 %attr(755,root,root) %{_pkglibdir}/*
91 %attr(4750,root,root) %{_sbindir}/fpexec
92 %attr(755,root,root) %{_sbindir}/fpstatic
This page took 0.107871 seconds and 4 git commands to generate.