]> git.pld-linux.org Git - packages/apache1-mod_frontpage.git/blob - apache1-mod_frontpage.spec
- use "%(%{apxs} -q SYSCONFDIR)" for _sysconfdir definition
[packages/apache1-mod_frontpage.git] / apache1-mod_frontpage.spec
1 %define         mod_name        frontpage
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        The improved mod_frontpage module for the Apache Web server
4 Summary(pl):    Ulepszony modu³ mod_frontpage dla serwera Apache
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.6.2
7 Release:        1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/mirfak/mod_%{mod_name}_mirfak-%{version}.tar.bz2
11 # Source0-md5:  f7480918382067ce16e7afc40a633be4
12 Source1:        %{name}.pl
13 Patch0:         %{name}-mirfak.patch
14 URL:            http://mirfak.sourceforge.net/
15 BuildRequires:  apache1-devel >= 1.3.23
16 BuildRequires:  %{__perl}
17 PreReq:         apache1 >= 1.3.23
18 Requires(post,preun):   %{apxs}
19 Requires:       apache1
20 Obsoletes:      apache-mod_%{mod_name} <= %{version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
25
26 %description
27 This is a module for the Apache HTTP Server
28 <http://www.apache.org/httpd.html>. It replaces the Apache-FP patches
29 and module supplied with the FrontPage Server Extensions available
30 from Microsoft <http://www.microsoft.com/> and Ready-to-Run Software
31 <http://www.rtr.com/fpsupport/>.
32
33 Using this module allows you to use advanced features of the FrontPage
34 client with your Apache HTTP Server (e.g. creating FrontPage-extended
35 subwebs using the FrontPage client in contrast to creating them as
36 user "root" with "fpinstall.sh" or the "fpsrvadm.exe"-utility on the
37 system's shell).
38
39 %description -l pl
40 To jest modu³ dla serwera HTTP Apache. Zastêpuje ³aty Apache-FP oraz
41 modu³ dodawany do FrontPage Server Extensions dostêpnych od Microsoftu
42 i Ready-to-Run Software (<http://www.rtr.com/fpsupport/>).
43
44 U¿ycie tego modu³u pozwala na u¿ywanie zaawansowanych mo¿liwo¶ci
45 klienta FrontPage z serwerem Apache (np. tworzenie podstron z
46 rozszerzeniami FrontPage przy u¿yciu klienta FrontPage zamiast przez
47 uruchamiania fpinstall.sh lub fpsrvadm.exe z pow³oki systemowej).
48
49 %prep
50 %setup -q -n mod_%{mod_name}_mirfak-%{version}
51 %patch0 -p1
52
53 %build
54 %{__perl} %{SOURCE1}
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sbindir}}
60
61 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
62 install fp{exec,static} $RPM_BUILD_ROOT%{_sbindir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
69 if [ -f /var/lock/subsys/apache ]; then
70         /etc/rc.d/init.d/apache restart 1>&2
71 fi
72
73 %preun
74 if [ "$1" = "0" ]; then
75         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
76         if [ -f /var/lock/subsys/apache ]; then
77                 /etc/rc.d/init.d/apache restart 1>&2
78         fi
79 fi
80
81 %files
82 %defattr(644,root,root,755)
83 %doc *.html CHANGES FEATURES README
84 %attr(755,root,root) %{_pkglibdir}/*
85 %attr(4750,root,root) %{_sbindir}/fpexec
86 %attr(755,root,root) %{_sbindir}/fpstatic
This page took 0.041852 seconds and 4 git commands to generate.