]> git.pld-linux.org Git - packages/apache1-mod_frontpage.git/blob - apache1-mod_frontpage.spec
- more specific Requires
[packages/apache1-mod_frontpage.git] / apache1-mod_frontpage.spec
1 %define         mod_name        frontpage
2 %define         arname          mod_%{mod_name}
3 %define         apxs            /usr/sbin/apxs
4
5 Summary:        The improved mod_frontpage module for the Apache Web server
6 Summary(pl):    Ulepszony modu³ mod_frontpage dla serwera Apache
7 Name:           apache-mod_%{mod_name}
8 Version:        1.6.1
9 Release:        2
10 License:        Apache
11 Group:          Networking/Daemons
12 #Source0: http://home.edo.uni-dortmund.de/~chripo/download/%{name}-%{version}mdk-1.3.19.tar.bz2
13 #The patch is now maintained by FreeBSD
14 Source0:        http://people.freebsd.org/~mbr/distfiles/mod_frontpage-%{version}.tar.bz2
15 # Source0-md5:  62a91d885ea6cfb7c45662d7315659d8
16 Patch0:         %{arname}-PLD.patch
17 Patch1:         %{arname}-Makefile.patch
18 Patch2:         %{arname}-fpexec-PLD.patch
19 URL:            http://home.edo.uni-dortmund.de/~chripo/
20 BuildRequires:  apache(EAPI)-devel >= 1.3.23
21 BuildRequires:  perl
22 PreReq:         apache(EAPI)  >= 1.3.23
23 Requires(post,preun):   %{apxs}
24 Requires:       apache
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      mod_frontpage
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
29 %define         _sysconfdir     /etc/httpd
30
31 %description
32 This is a module for the Apache HTTP Server
33 <http://www.apache.org/httpd.html>. It replaces the Apache-FP patches
34 and module supplied with the FrontPage Server Extensions available
35 from Microsoft <http://www.microsoft.com/> and Ready-to-Run Software
36 <http://www.rtr.com/fpsupport/>.
37
38 Using this module allows you to use advanced features of the FrontPage
39 client with your Apache HTTP Server (e.g. creating FrontPage-extended
40 subwebs using the FrontPage client in contrast to creating them as
41 user "root" with "fpinstall.sh" or the "fpsrvadm.exe"-utility on the
42 system's shell).
43
44 %description -l pl
45 To jest modu³ dla serwera HTTP Apache. Zastêpuje ³aty Apache-FP oraz
46 modu³ dodawany do FrontPage Server Extensions dostêpnych od Microsoftu
47 i Ready-to-Run Software (<http://www.rtr.com/fpsupport/>).
48
49 U¿ycie tego modu³u pozwala na u¿ywanie zaawansowanych mo¿liwo¶ci
50 klienta FrontPage z serwerem Apache (np. tworzenie podstron z
51 rozszerzeniami FrontPage przy u¿yciu klienta FrontPage zamiast przez
52 uruchamiania fpinstall.sh lub fpsrvadm.exe z pow³oki systemowej).
53
54 %prep
55 %setup -q -n %{arname}-%{version}
56 %patch -p0
57 %patch1 -p0
58 %patch2 -p0
59
60 %build
61 perl Makefile.PL
62 %{__make} \
63         CFLAGS="%{rpmcflags} -DLINUX=22 -DINET6 -Dss_family=__ss_family -Dss_len=__ss_len -DDEV_RANDOM=/dev/random -DEAPI -DEAPI_MM"
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sbindir}}
68
69 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
70 install fp{exec,static} $RPM_BUILD_ROOT%{_sbindir}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
77 if [ -f /var/lock/subsys/httpd ]; then
78         /etc/rc.d/init.d/httpd restart 1>&2
79 fi
80
81 %preun
82 if [ "$1" = "0" ]; then
83         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
84         if [ -f /var/lock/subsys/httpd ]; then
85                 /etc/rc.d/init.d/httpd restart 1>&2
86         fi
87 fi
88
89 %files
90 %defattr(644,root,root,755)
91 %doc CHANGES FEATURES LICENSE README
92 %attr(755,root,root) %{_pkglibdir}/*
93 %attr(4750,root,root) %{_sbindir}/fpexec
94 %attr(755,root,root) %{_sbindir}/fpstatic
This page took 0.070952 seconds and 3 git commands to generate.