]> git.pld-linux.org Git - packages/apache1-mod_frontpage.git/blob - apache1-mod_frontpage.spec
- rel 3 (R: apache1(EAPI) instead of apache1)
[packages/apache1-mod_frontpage.git] / apache1-mod_frontpage.spec
1 %define         mod_name        frontpage
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        The improved mod_frontpage module for the Apache Web server
4 Summary(pl):    Ulepszony modu³ mod_frontpage dla serwera Apache
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.6.2
7 Release:        3
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/mirfak/mod_%{mod_name}_mirfak-%{version}.tar.bz2
11 # Source0-md5:  f7480918382067ce16e7afc40a633be4
12 Source1:        %{name}.pl
13 Patch0:         %{name}-mirfak.patch
14 URL:            http://mirfak.sourceforge.net/
15 BuildRequires:  %{__perl}
16 BuildRequires:  apache1-devel >= 1.3.33-2
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires(triggerpostun):        %{apxs}
19 Requires:       apache1(EAPI)
20 Obsoletes:      apache-mod_frontpage <= 1.6.2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25
26 %description
27 This is a module for the Apache HTTP Server
28 <http://httpd.apache.org/>. It replaces the Apache-FP patches and
29 module supplied with the FrontPage Server Extensions available from
30 Microsoft <http://www.microsoft.com/> and Ready-to-Run Software
31 <http://www.rtr.com/fpsupport/>.
32
33 Using this module allows you to use advanced features of the FrontPage
34 client with your Apache HTTP Server (e.g. creating FrontPage-extended
35 subwebs using the FrontPage client in contrast to creating them as
36 user "root" with "fpinstall.sh" or the "fpsrvadm.exe"-utility on the
37 system's shell).
38
39 %description -l pl
40 To jest modu³ dla serwera HTTP Apache. Zastêpuje ³aty Apache-FP oraz
41 modu³ dodawany do FrontPage Server Extensions dostêpnych od Microsoftu
42 i Ready-to-Run Software (<http://www.rtr.com/fpsupport/>).
43
44 U¿ycie tego modu³u pozwala na u¿ywanie zaawansowanych mo¿liwo¶ci
45 klienta FrontPage z serwerem Apache (np. tworzenie podstron z
46 rozszerzeniami FrontPage przy u¿yciu klienta FrontPage zamiast przez
47 uruchamiania fpinstall.sh lub fpsrvadm.exe z pow³oki systemowej).
48
49 %prep
50 %setup -q -n mod_%{mod_name}_mirfak-%{version}
51 %patch0 -p1
52
53 %build
54 %{__perl} %{SOURCE1}
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_sbindir}}
60
61 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
62 install fp{exec,static} $RPM_BUILD_ROOT%{_sbindir}
63
64 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
65         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 %service -q apache restart
72
73 %postun
74 if [ "$1" = "0" ]; then
75         %service -q apache restart
76 fi
77
78 %triggerpostun -- apache1-mod_%{mod_name} < 1.6.2-1.1
79 # check that they're not using old apache.conf
80 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
81         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc *.html CHANGES FEATURES README
87 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
88 %attr(755,root,root) %{_pkglibdir}/*
89 %attr(4750,root,root) %{_sbindir}/fpexec
90 %attr(755,root,root) %{_sbindir}/fpstatic
This page took 0.041786 seconds and 3 git commands to generate.