]> git.pld-linux.org Git - packages/apache1-mod_frontpage.git/blob - apache1-mod_frontpage.spec
27343441f07bf493e9e3fc136e07ce8b68d7be52
[packages/apache1-mod_frontpage.git] / apache1-mod_frontpage.spec
1 %define         mod_name        frontpage
2 %define         arname          mod_%{mod_name}
3 %define         apxs            /usr/sbin/apxs
4
5 Summary:        The improved mod_frontpage module for the Apache Web server
6 Summary(pl):    Ulepszony modu³ mod_frontpage dla serwera Apache
7 Name:           apache-mod_%{mod_name}
8 Version:        1.6.2
9 Release:        1
10 License:        Apache
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/mirfak/mod_%{mod_name}_mirfak-%{version}.tar.bz2
13 # Source0-md5:  f7480918382067ce16e7afc40a633be4
14 Source1:        %{name}.pl
15 Patch0:         %{name}-mirfak.patch
16 URL:            http://mirfak.sourceforge.net/
17 BuildRequires:  apache(EAPI)-devel >= 1.3.23
18 BuildRequires:  perl
19 PreReq:         apache(EAPI) >= 1.3.23
20 Requires(post,preun):   %{apxs}
21 Requires:       apache
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 Obsoletes:      mod_frontpage
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
26 %define         _sysconfdir     /etc/httpd
27
28 %description
29 This is a module for the Apache HTTP Server
30 <http://www.apache.org/httpd.html>. It replaces the Apache-FP patches
31 and module supplied with the FrontPage Server Extensions available
32 from Microsoft <http://www.microsoft.com/> and Ready-to-Run Software
33 <http://www.rtr.com/fpsupport/>.
34
35 Using this module allows you to use advanced features of the FrontPage
36 client with your Apache HTTP Server (e.g. creating FrontPage-extended
37 subwebs using the FrontPage client in contrast to creating them as
38 user "root" with "fpinstall.sh" or the "fpsrvadm.exe"-utility on the
39 system's shell).
40
41 %description -l pl
42 To jest modu³ dla serwera HTTP Apache. Zastêpuje ³aty Apache-FP oraz
43 modu³ dodawany do FrontPage Server Extensions dostêpnych od Microsoftu
44 i Ready-to-Run Software (<http://www.rtr.com/fpsupport/>).
45
46 U¿ycie tego modu³u pozwala na u¿ywanie zaawansowanych mo¿liwo¶ci
47 klienta FrontPage z serwerem Apache (np. tworzenie podstron z
48 rozszerzeniami FrontPage przy u¿yciu klienta FrontPage zamiast przez
49 uruchamiania fpinstall.sh lub fpsrvadm.exe z pow³oki systemowej).
50
51 %prep
52 %setup -q -n %{arname}_mirfak-%{version}
53 %patch0 -p1
54
55 %build
56 perl %{SOURCE1}
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sbindir}}
62
63 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
64 install fp{exec,static} $RPM_BUILD_ROOT%{_sbindir}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
71 if [ -f /var/lock/subsys/httpd ]; then
72         /etc/rc.d/init.d/httpd restart 1>&2
73 fi
74
75 %preun
76 if [ "$1" = "0" ]; then
77         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
78         if [ -f /var/lock/subsys/httpd ]; then
79                 /etc/rc.d/init.d/httpd restart 1>&2
80         fi
81 fi
82
83 %files
84 %defattr(644,root,root,755)
85 %doc *.html CHANGES FEATURES README
86 %attr(755,root,root) %{_pkglibdir}/*
87 %attr(4750,root,root) %{_sbindir}/fpexec
88 %attr(755,root,root) %{_sbindir}/fpstatic
This page took 0.056776 seconds and 2 git commands to generate.