]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blobdiff - apache1-mod_fastcgi.spec
- added
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
index 31c3806d57db44b28dd5736abf6214ca9da0fecf..0be4dae6f4aa7d455a0f1c3f203412337cac34cb 100644 (file)
@@ -1,16 +1,24 @@
+%define        apxs    /usr/sbin/apxs
 Summary:       Support for the FastCGI protocol for apache webserver
+Summary(pl):   Obs³uga protoko³u FastCGI dla serwera apache
+Summary(ru):   FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
+Summary(uk):   FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
 Name:          apache-mod_fastcgi
-Version:       2.2.8
-Release:       2
-Copyright:     Open Market
+Version:       2.4.0
+Release:       1
+License:       distributable
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
+Source0:       http://www.FastCGI.com/dist/mod_fastcgi-%{version}.tar.gz
+# Source0-md5: e4f5b1b185db4774021163dd0fcd2c56
 URL:           http://www.FastCGI.com/
-Source0:       http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
+BuildRequires: %{apxs}
+BuildRequires: apache-devel
+Requires(post,preun):  %{apxs}
 Requires:      apache >= 1.3.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-BuildRequires: apache-devel
+
+%define         _libexecdir     %{_libdir}/apache
+%define         _htmldocdir     /home/httpd/manual/mod
 
 %description
 This 3rd party module provides support for the FastCGI protocol.
@@ -18,30 +26,43 @@ FastCGI is a language independent, scalable, open extension to CGI
 that provides high performance and persistence without the limitations
 of server specific APIs.
 
-%define         _libexecdir     /usr/lib/apache
-%define         _htmldocdir     /home/httpd/html/docs/%{name}_%{version}
+%description -l pl
+To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
+niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
+du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
+
+%description -l ru
+FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
+×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
+ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
+
+óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
+
+%description -l uk
+FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
+×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
+ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
+
+û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
 
 %prep
-%setup -q -n mod_fastcgi_%{version}
+%setup -q -n mod_fastcgi-%{version}
 
 %build
-apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
-strip mod_fastcgi.so
+%{apxs} -D SUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_fastcgi.so -c *.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
 
 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
-
 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
 
-gzip -9nf docs/LICENSE.TERMS CHANGES
-
-strip --strip-unneeded $RPM_BUILD_ROOT%{_libexecdir}/*
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
+%{apxs} -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
@@ -50,17 +71,14 @@ fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
+       %{apxs} -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
-%doc docs/*.gz CHANGES.gz
-%doc %{_htmldocdir}
+%doc docs/LICENSE.TERMS CHANGES
+%doc %{_htmldocdir}/*
 %attr(755,root,root) %{_libexecdir}/*
This page took 0.146908 seconds and 4 git commands to generate.