]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blob - apache1-mod_fastcgi.spec
- restart apache in %postun rather in %preun as the config file, loading module
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
1 %define         mod_name        fastcgi
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Support for the FastCGI protocol for apache webserver
4 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
5 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
6 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
7 Name:           apache1-mod_%{mod_name}
8 # NOTE: remember about apache-mod_fastcgi.spec when messing here
9 Version:        2.4.2
10 Release:        1.2
11 License:        distributable
12 Group:          Networking/Daemons
13 Source0:        http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  e994414304b535cb99e10b7d1cad1d1e
15 Patch0:         %{name}-allow-uid-gid.patch
16 URL:            http://www.FastCGI.com/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache1-devel >= 1.3.33-2
19 BuildRequires:  libtool
20 Requires:       apache1 >= 1.3.33-2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25
26 %description
27 This 3rd party module provides support for the FastCGI protocol.
28 FastCGI is a language independent, scalable, open extension to CGI
29 that provides high performance and persistence without the limitations
30 of server specific APIs.
31
32 %description -l pl
33 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
34 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
35 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
36
37 %description -l ru
38 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
39 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
40 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
41
42 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
43
44 %description -l uk
45 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
46 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
47 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
48
49 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
50
51 %prep
52 %setup -q -n mod_%{mod_name}-%{version}
53 %patch0 -p1
54
55 %build
56 %{apxs} -o mod_%{mod_name}.so -c *.c
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
61
62 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
63
64 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
65         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 if [ -f /var/lock/subsys/apache ]; then
72         /etc/rc.d/init.d/apache restart 1>&2
73 else
74         echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
75 fi
76
77 %postun
78 if [ "$1" = "0" ]; then
79         if [ -f /var/lock/subsys/apache ]; then
80                 /etc/rc.d/init.d/apache restart 1>&2
81         fi
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc docs/LICENSE.TERMS CHANGES docs/*.html
87 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
88 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.071886 seconds and 3 git commands to generate.