]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blame_incremental - apache1-mod_fastcgi.spec
- typo
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
... / ...
CommitLineData
1Summary: Support for the FastCGI protocol for apache webserver
2Name: apache-mod_fastcgi
3Version: 2.2.8
4Release: 2
5Copyright: Open Market
6Group: Networking/Daemons
7Group(de): Netzwerkwesen/Server
8Group(pl): Sieciowe/Serwery
9URL: http://www.FastCGI.com/
10Source0: http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
11Requires: apache >= 1.3.1
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13BuildRequires: apache-devel
14
15%description
16This 3rd party module provides support for the FastCGI protocol.
17FastCGI is a language independent, scalable, open extension to CGI
18that provides high performance and persistence without the limitations
19of server specific APIs.
20
21%define _libexecdir /usr/lib/apache
22%define _htmldocdir /home/httpd/html/docs/%{name}_%{version}
23
24%prep
25%setup -q -n mod_fastcgi_%{version}
26
27%build
28apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
29strip mod_fastcgi.so
30
31%install
32rm -rf $RPM_BUILD_ROOT
33install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
34
35install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
36
37install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
38
39gzip -9nf docs/LICENSE.TERMS CHANGES
40
41strip --strip-unneeded $RPM_BUILD_ROOT%{_libexecdir}/*
42
43%post
44%{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
45if [ -f /var/lock/subsys/httpd ]; then
46 /etc/rc.d/init.d/httpd restart 1>&2
47else
48 echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
49fi
50
51%preun
52if [ "$1" = "0" ]; then
53 %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
54 if [ -f /var/lock/subsys/httpd ]; then
55 /etc/rc.d/init.d/httpd restart 1>&2
56 fi
57fi
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc docs/*.gz CHANGES.gz
65%doc %{_htmldocdir}
66%attr(755,root,root) %{_libexecdir}/*
This page took 0.023518 seconds and 4 git commands to generate.