]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blame - apache1-mod_fastcgi.spec
- removed stripping executables, it's done by rpm automation
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
CommitLineData
74a814af
JR
1Summary: Support for the FastCGI protocol for apache webserver
2Name: apache-mod_fastcgi
39a2eb88 3Version: 2.2.10
eb6ccd6c 4Release: 2
74a814af
JR
5Copyright: Open Market
6Group: Networking/Daemons
7Group(de): Netzwerkwesen/Server
8Group(pl): Sieciowe/Serwery
74a814af 9Source0: http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
ad6ad464 10URL: http://www.FastCGI.com/
11BuildRequires: apache-devel
74a814af
JR
12Requires: apache >= 1.3.1
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74a814af 14
f2a0f991 15%define _libexecdir %{_libdir}/apache
eb6ccd6c 16%define _htmldocdir /home/httpd/manual/mod
f2a0f991 17
74a814af
JR
18%description
19This 3rd party module provides support for the FastCGI protocol.
20FastCGI is a language independent, scalable, open extension to CGI
21that provides high performance and persistence without the limitations
22of server specific APIs.
23
74a814af
JR
24%prep
25%setup -q -n mod_fastcgi_%{version}
26
27%build
6871e3f2 28apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
74a814af
JR
29
30%install
31rm -rf $RPM_BUILD_ROOT
32install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
33
34install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
35
36install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
37
38gzip -9nf docs/LICENSE.TERMS CHANGES
39
1f0682ac
JR
40%post
41%{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
42if [ -f /var/lock/subsys/httpd ]; then
43 /etc/rc.d/init.d/httpd restart 1>&2
44else
45 echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
46fi
47
48%preun
49if [ "$1" = "0" ]; then
50 %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
51 if [ -f /var/lock/subsys/httpd ]; then
52 /etc/rc.d/init.d/httpd restart 1>&2
53 fi
54fi
55
74a814af
JR
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%files
60%defattr(644,root,root,755)
f2a0f991 61%doc docs/*.gz *.gz
74a814af
JR
62%doc %{_htmldocdir}
63%attr(755,root,root) %{_libexecdir}/*
This page took 0.834998 seconds and 4 git commands to generate.