]> git.pld-linux.org Git - packages/apache1-mod_dynvhost.git/blobdiff - apache1-mod_dynvhost.spec
- restart apache in %postun rather in %preun as the config file, loading module
[packages/apache1-mod_dynvhost.git] / apache1-mod_dynvhost.spec
index a0970d26a3128a947fe852daf6cfee0f9fe10bbe..8ed669ab6839d1568e83a520a5b657796af8dc12 100644 (file)
@@ -1,27 +1,30 @@
 %define                mod_name        dynvhost
-%define        apxs            /usr/sbin/apxs
+%define        apxs            /usr/sbin/apxs1
 Summary:       Dynamic Virtual Hosting
 Summary(pl):   Dynamiczne Serwery Wirtualne
-Name:          apache-mod_%{mod_name}
+Name:          apache1-mod_%{mod_name}
 Version:       1
-Release:       2
+Release:       3
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://funkcity.com/0101/projects/dynvhost/mod_%{mod_name}.tar.gz
+# Source0-md5: 7608ca6ce5c906bfe960cd0f92bdb6d8
 URL:           http://funkcity.com/0101/
 BuildRequires: %{apxs}
-BuildRequires: apache(EAPI)-devel
+BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: zlib-devel
-Prereq:                %{_sbindir}/apxs
-Requires:      apache(EAPI)
+Requires(triggerpostun):       %{apxs}
+Requires:      apache1 >= 1.3.33-2
+Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 The "mod_dynvhost" module will create pseudo name based VirtualHosts
 on the fly. All you need is a directory with the fully qualified
-domain name ( FQDN ) of your virtual site and the module will take
+domain name (FQDN) of your virtual site and the module will take
 care of the rest.
 
 %description -l pl
@@ -37,30 +40,36 @@ Modu
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
-gzip -9nf README ChangeLog
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 fi
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%triggerpostun -- apache1-mod_%{mod_name} < 1-2.1
+# check that they're not using old apache.conf
+if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+fi
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
+%doc README ChangeLog
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.041025 seconds and 4 git commands to generate.