]> git.pld-linux.org Git - packages/apache1-mod_dav.git/commitdiff
- added %{apxs} local macro to avoid adapter problems
authorankry <ankry@pld-linux.org>
Sun, 17 Feb 2002 19:01:42 +0000 (19:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix use of %{apxs} and %{_sbindir}/apxs
- added BR %{apxs} & Prereq %{_sbindir}/apxs (if necessary); removed BR apache

Changed files:
    apache1-mod_dav.spec -> 1.13

apache1-mod_dav.spec

index 50e3bd16b0269eae1af0a61daeddd535fc075623..873ab35bc9d707a6dd5000f3c39fd0fedf7677e8 100644 (file)
@@ -1,3 +1,4 @@
+%define        apxs    /usr/sbin/apxs
 Summary:       WebDAV module for the Apache Web server
 Summary(cs):   DAV modul pro WWW server Apache
 Summary(da):   En DAV-modul for Apache
@@ -35,8 +36,8 @@ Group(sv):    N
 Group(uk):     íÅÒÅÖÁ/äÅÍÏÎÉ
 Source0:       http://www.webdav.org/mod_dav/mod_%{mod_name}-%{version}-%{apache_version}.tar.gz
 URL:           http://www.webdav.org/mod_dav/
-Prereq:                /usr/sbin/apxs
-BuildRequires: /usr/sbin/apxs
+Prereq:                %{_sbindir}/apxs
+BuildRequires: %{apxs}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: apache(EAPI)-devel      >= %{apache_version}
@@ -44,7 +45,7 @@ Requires:     apache(EAPI)            >= %{apache_version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     mod_dav
 
-%define                _pkglibdir      %(%{_sbindir}/apxs -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 mod_dav enables Apache to understand DAV protocol (extensions to
@@ -151,8 +152,8 @@ Fusion צ
 aclocal
 autoconf
 %configure \
-       --with-apxs=/usr/sbin/apxs
-%{__make} APXS=/usr/sbin/apxs
+       --with-apxs=%{apxs}
+%{__make} APXS=%{apxs}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -163,14 +164,14 @@ install lib%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/
 gzip -9nf README CHANGES INSTALL
 
 %post
-/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/lib%{mod_name}.so 1>&2
+%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/lib%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/lib%{mod_name}.so 1>&2
+       %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/lib%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
This page took 0.079936 seconds and 4 git commands to generate.