]> git.pld-linux.org Git - packages/apache1-mod_cvs.git/commitdiff
- initial release
authorwaszi <waszi@pld-linux.org>
Mon, 21 Feb 2000 13:36:44 +0000 (13:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache1-mod_cvs.spec -> 1.1

apache1-mod_cvs.spec [new file with mode: 0644]

diff --git a/apache1-mod_cvs.spec b/apache1-mod_cvs.spec
new file mode 100644 (file)
index 0000000..f4abebb
--- /dev/null
@@ -0,0 +1,61 @@
+%define                mod_name        cvs
+Summary:       Apache module: Automatically updates files in a CVS-based webtree.
+Summary(pl):   Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS
+Name:          apache-mod_%{mod_name}
+Version:       0.4
+Release:       1
+Copyright:     GPL
+Group:         Networking/Daemons
+Group(pl):     Sieciowe/Serwery
+Source0:       mod_%{mod_name}-%{version}.tar.gz
+URL:           http://www.sub.nu/mod_cvs/
+BuildRequires: /usr/sbin/apxs
+BuildRequires: apache-devel
+BuildRequires: zlib-devel
+Prereq:                /usr/sbin/apxs
+Requires:      apache
+BuildRoot:     /tmp/%{name}-%{version}-root
+
+%define                _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
+
+%description
+Apache module: On-the-fly decompression of HTML documents.
+
+%description -l pl
+Modu³ do apache: dekompresuje dokumenty HTML w locie.
+
+%prep 
+%setup -q -n mod_%{mod_name}-%{version}
+
+%build
+/usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT%{_pkglibdir}
+
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+strip --strip-unneeded $RPM_BUILD_ROOT%{_pkglibdir}/* 
+
+%post
+/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+if [ -f /var/lock/subsys/httpd ]; then
+       /etc/rc.d/init.d/httpd restart 1>&2
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
+fi
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_pkglibdir}/*
This page took 0.095252 seconds and 4 git commands to generate.