]> git.pld-linux.org Git - packages/apache1-mod_cvs.git/blobdiff - apache1-mod_cvs.spec
- confdir enabled apache1
[packages/apache1-mod_cvs.git] / apache1-mod_cvs.spec
index 6a85802367e3dfdf3186e1c834251421db2d418b..fedac06f15b75e11d0a7944f0c41545aad0166ed 100644 (file)
@@ -4,7 +4,7 @@ Summary:        Apache module: Automatically updates files in a CVS-based webtree
 Summary(pl):   Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS
 Name:          apache1-mod_%{mod_name}
 Version:       0.5
-Release:       1
+Release:       1.4
 License:       GPL
 Group:         Networking/Daemons
 # working URL: http://www.sub.nu/mod_cvs/src/
@@ -13,14 +13,15 @@ Source0:    ftp://ftp.sub.nu/pub/mod_cvs/mod_%{mod_name}-%{version}.tar.gz
 # Source0-md5: e2cfe7818337915e6cbaffa45852012f
 URL:           http://www.sub.nu/mod_cvs/
 BuildRequires: %{apxs}
-BuildRequires: apache1-devel
+BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: zlib-devel
-Requires(post,preun):  %{apxs}
-Requires:      apache1
+Requires(triggerpostun):       %{apxs}
+Requires:      apache1 >= 1.3.33-2
 Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 Apache module: Automatically updates files in a CVS-based webtree.
@@ -36,28 +37,36 @@ Modu
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/apache ]; then
        /etc/rc.d/init.d/apache restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/apache ]; then
                /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
+%triggerpostun -- apache1-mod_%{mod_name} < 0.5-1.1
+# check that they're not using old apache.conf
+if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc README
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.12481 seconds and 4 git commands to generate.