]> git.pld-linux.org Git - packages/apache1-mod_chroot.git/blame - apache1-mod_chroot.spec
- use apache1(EAPI) for runtime dep
[packages/apache1-mod_chroot.git] / apache1-mod_chroot.spec
CommitLineData
3586642b 1%define mod_name chroot
2%define apxs /usr/sbin/apxs1
31e2af17 3Summary: Apache module: makes running Apache in a secure chroot environment easy
60f7278b 4Summary(pl.UTF-8): Moduł Apache'a do uruchamiania serwera w bezpiecznym środowisku chroot
3586642b 5Name: apache1-mod_%{mod_name}
61e0db1b 6Version: 0.5
26ca817f 7Release: 0.5
3586642b 8License: GPL
9Group: Networking/Daemons
10Source0: http://core.segfault.pl/~hobbit/mod_chroot/dist/mod_chroot-%{version}.tar.gz
61e0db1b 11# Source0-md5: d72716052faa3bdd3371210f26b13f38
3586642b 12URL: http://core.segfault.pl/~hobbit/mod_chroot/
014476ee 13BuildRequires: apache1-devel >= 1.3.39
666d609f 14BuildRequires: rpmbuild(macros) >= 1.268
26ca817f 15Requires: apache1(EAPI)
3586642b 16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
01afa4e3
ER
18%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
19%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
3586642b 20
21%description
22mod_chroot makes running Apache in a secure chroot environment easy.
23You don't need to create a special directory hierarchy containing
24/dev, /lib, /etc...
25
82b2b678
JR
26%description -l pl.UTF-8
27mod_chroot ułatwia uruchamianie Apache'a w bezpiecznym środowisku
28chroot. Nie trzeba tworzyć specjalnej hierarchii katalogów /dev, /lib,
f0b659f6 29/etc, itp.
31e2af17 30
3586642b 31%prep
32%setup -q -n mod_%{mod_name}-%{version}
33
34%build
35%{apxs} -c mod_%{mod_name}.c
36
37%install
38rm -rf $RPM_BUILD_ROOT
39
01afa4e3
ER
40install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
41install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
42
43echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
44 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
3586642b 45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
01afa4e3 49%post
666d609f 50%service -q apache restart
01afa4e3 51
4bbb4213 52%postun
01afa4e3 53if [ "$1" = "0" ]; then
666d609f 54 %service -q apache restart
01afa4e3
ER
55fi
56
3586642b 57%files
58%defattr(644,root,root,755)
872b8ea8 59%doc CAVEATS ChangeLog INSTALL README
5b1a0125 60%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
3586642b 61%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.079622 seconds and 4 git commands to generate.