]> git.pld-linux.org Git - packages/apache1-mod_become.git/blob - apache1-mod_become.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_become.git] / apache1-mod_become.spec
1 %define         mod_name        become
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: Become Somebody
4 Summary(pl.UTF-8):      Moduł Apache'a: stawanie się kimś
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.3
7 Release:        3
8 License:        ?
9 Group:          Networking/Daemons
10 Source0:        http://www.snert.com/Software/mod_become/mod_become103.tgz
11 # Source0-md5:  7bb1607587687dabc711b3b1903947e5
12 URL:            http://www.snert.com/Software/mod_become/
13 BuildRequires:  apache1-devel >= 1.3.39
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 Requires(triggerpostun):        %{apxs}
16 Requires:       apache1(EAPI)
17 Obsoletes:      apache-mod_become <= 1.3
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
21 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
22
23 %description
24 This module enables the web server to take on the access rights of a
25 user & group, so that users can make available files to the web
26 without having to make them readable by the world on the local file
27 system. This can be useful for sites with a large number of users who
28 want to apply file access controls among themselves. This module can
29 also be applied to virtual hosts, directories, and locations.
30
31 %description -l pl.UTF-8
32 Ten moduł pozwala serwerowi WWW przejąć prawa dostępu użytkownika i
33 grupy, dzięki czemu użytkownicy mogą udostępnić pliki na WWW bez
34 czynienia ich globalnie czytelnymi w lokalnym systemie plików. Może to
35 być przydatne na dla serwerów z dużą liczbą użytkowników, którzy chcą
36 kontrolować dostęp do plików między sobą. Ten moduł może być używany
37 także z serwerami wirtualnymi, katalogami i miejscami.
38
39 %prep
40 %setup -q -n mod_%{mod_name}-%{version}
41
42 %build
43 PATH=$PATH:%{_sbindir}
44 %{__make} build-dynamic \
45         APXS=%{apxs}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
50
51 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
52
53 echo '#LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
54         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 echo "mod_%{mod_name}: This module is not turned on by default; if you're sure,"
61 echo "mod_%{mod_name}: uncomment the appropriate line in Apache's config file."
62
63 %postun
64 if [ "$1" = "0" ]; then
65         %service -q apache restart
66 fi
67
68 %triggerpostun -- apache1-mod_%{mod_name} < 1.3-1.1
69 # check that they're not using old apache.conf
70 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
71         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc CHANGES.txt LICENSE.txt SECURITY.txt index.shtml notes-conf.txt
77 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
78 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.056174 seconds and 3 git commands to generate.