]> git.pld-linux.org Git - packages/apache1-mod_become.git/blob - apache1-mod_become.spec
- use "%(%{apxs} -q SYSCONFDIR)" for _sysconfdir definition
[packages/apache1-mod_become.git] / apache1-mod_become.spec
1 %define         mod_name        become
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: Become Somebody
4 Summary(pl):    Modu³ Apache'a: stawanie siê kim¶
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.3
7 Release:        1
8 License:        ?
9 Group:          Networking/Daemons
10 Source0:        http://www.snert.com/Software/mod_become/mod_become103.tgz
11 # Source0-md5:  7bb1607587687dabc711b3b1903947e5
12 URL:            http://www.snert.com/Software/mod_become/
13 BuildRequires:  apache1-devel
14 BuildRequires:  %{apxs}
15 Requires(post,preun):   %{apxs}
16 Requires(post,preun):   grep
17 Requires(preun):        fileutils
18 Requires:       apache1
19 Obsoletes:      apache-mod_%{mod_name} <= %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
24
25 %description
26 This module enables the web server to take on the access rights of a
27 user & group, so that users can make available files to the web
28 without having to make them readable by the world on the local file
29 system. This can be useful for sites with a large number of users who
30 want to apply file access controls among themselves. This module can
31 also be applied to virtual hosts, directories, and locations.
32
33 %description -l pl
34 Ten modu³ pozwala serwerowi WWW przej±æ prawa dostêpu u¿ytkownika i
35 grupy, dziêki czemu u¿ytkownicy mog± udostêpniæ pliki na WWW bez
36 czynienia ich globalnie czytelnymi w lokalnym systemie plików. Mo¿e to
37 byæ przydatne na dla serwerów z du¿± liczb± u¿ytkowników, którzy chc±
38 kontrolowaæ dostêp do plików miêdzy sob±. Ten modu³ mo¿e byæ u¿ywany
39 tak¿e z serwerami wirtualnymi, katalogami i miejscami.
40
41 %prep
42 %setup -q -n mod_%{mod_name}-%{version}
43
44 %build
45 PATH=$PATH:%{_sbindir}
46 %{__make} build-dynamic \
47         APXS=%{apxs}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
52
53 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so
60 echo "mod_%{mod_name}: this module is not turned on by default; if you're sure,"
61 echo "mod_%{mod_name}: uncomment the appropriate line in Apache's config file"
62
63 %preun
64 if [ "$1" = "0" ]; then
65         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
66         if [ -f /var/lock/subsys/apache ]; then
67                 /etc/rc.d/init.d/apache restart 1>&2
68         fi
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc CHANGES.txt LICENSE.txt SECURITY.txt index.shtml notes-conf.txt
74 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.072849 seconds and 3 git commands to generate.