]> git.pld-linux.org Git - packages/apache1-mod_auth_samba.git/commitdiff
- added %{apxs} local macro to avoid adapter problems
authorankry <ankry@pld-linux.org>
Sun, 17 Feb 2002 19:01:42 +0000 (19:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix use of %{apxs} and %{_sbindir}/apxs
- added BR %{apxs} & Prereq %{_sbindir}/apxs (if necessary); removed BR apache

Changed files:
    apache1-mod_auth_samba.spec -> 1.10

apache1-mod_auth_samba.spec

index eacf7eaf917a2457184606af9c41020cdcd1a68b..0fc9b8ff7e36b65da00acd3c024d7b83c3510157 100644 (file)
@@ -1,4 +1,5 @@
 %define                mod_name        auth_samba
+%define        apxs    /usr/sbin/apxs
 Summary:       This is the samba authentication module for Apache
 Summary(pl):   Modu³ autentykacji samba dla Apache
 Name:          apache-mod_%{mod_name}
@@ -11,17 +12,17 @@ Group(pl):  Sieciowe/Serwery
 Source0:       ftp://download.sourceforge.net/pub/sourceforge/modauthsamba/mod_%{mod_name}-%{version}.tar.gz
 Patch0:                %{name}-symbol_fix.patch
 URL:           http://modauthsamba.sourceforge.net/
-BuildRequires: /usr/sbin/apxs
+BuildRequires: %{apxs}
 BuildRequires: apache(EAPI)-devel
 BuildRequires: gdbm-devel
 BuildRequires: pam-devel
 BuildRequires: pam_smb
-Prereq:                /usr/sbin/apxs
+Prereq:                %{_sbindir}/apxs
 Requires:      pam_smb
 Requires:      apache(EAPI)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 This is an authentication module for Apache that allows you to
@@ -36,7 +37,7 @@ klient
 %patch0 -p1
 
 %build
-/usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lgdbm -lcrypt -lpam /lib/security/pam_smb_auth.so
+%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lgdbm -lcrypt -lpam /lib/security/pam_smb_auth.so
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -48,14 +49,14 @@ install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
This page took 0.090133 seconds and 4 git commands to generate.