]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blame - apache1-mod_auth_pgsql.spec
- tabs in preamble
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
CommitLineData
2cc115fb 1%define mod_name auth_pgsql
667576b5 2%define apxs /usr/sbin/apxs1
f430050e 3Summary: This is the PostgreSQL authentication module for Apache
8bbab28d
ER
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí PostgreSQL
5Summary(da.UTF-8): Autenticering for webtjeneren Apache fra en PostgreSQL-database
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7Summary(es.UTF-8): Autenticación vía PostgreSQL para Apache
8Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9Summary(it.UTF-8): Autenticazione di base per il server web Apache mediante un database PostgreSQL
10Summary(ja.UTF-8): PostgreSQL データベースを使った Apache Web サーバーへの基本認証
11Summary(nb.UTF-8): Autentisering for webtjeneren Apache fra en PostgreSQL-database
12Summary(pl.UTF-8): Moduł uwierzytelnienia PostgreSQL dla Apache
13Summary(pt_BR.UTF-8): Autenticação via PostgreSQL para o Apache
14Summary(sv.UTF-8): Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
667576b5 15Name: apache1-mod_%{mod_name}
ac317567 16Version: 0.9.12
f01493f7 17Release: 4
2cc115fb
SZ
18License: GPL
19Group: Networking/Daemons
2cc115fb 20Source0: http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
6386825e 21# Source0-md5: 7be403b7487c13cdb023cc526ee2e13a
21a4c8eb 22URL: http://www.giuseppetanzilli.it/mod_auth_pgsql/
cb7cbee3 23BuildRequires: %{apxs}
bbe08d31 24BuildRequires: apache1-devel >= 1.3.33-2
667576b5 25BuildRequires: postgresql-devel >= 7
c2268964 26BuildRequires: rpmbuild(macros) >= 1.268
bbe08d31 27Requires(triggerpostun): %{apxs}
f01493f7 28Requires: apache1(EAPI)
12b09ef4 29Obsoletes: apache-mod_auth_pgsql <= 0.9.12
2cc115fb
SZ
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
bbe08d31
ER
32%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
33%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
2cc115fb
SZ
34
35%description
36This is an authentication module for Apache that allows you to
3d064fe4 37authenticate HTTP clients using PostgreSQL RDBMS.
2cc115fb 38
b55a97e9
JR
39%description -l cs.UTF-8
40Balíček mod_auth_pgsql slouží pro omezení přístupu k dokumentům, které
41poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
f430050e 42PostgreSQL.
43
b55a97e9 44%description -l de.UTF-8
f430050e 45Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
b55a97e9
JR
46Web- Server bediente Dokumente zu beschränken, indem es die Felder in
47einer Tabelle in einer PostgresQL-Datenbank prüft.
f430050e 48
b55a97e9 49%description -l es.UTF-8
f430050e 50Mod_auth_pgsql puede usarse para limitar el acceso a documentos
51servidos desde un servidor web verificando datos en una base de datos
52PostgreSQL.
53
b55a97e9
JR
54%description -l fr.UTF-8
55mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
56servis par un serveur Web en vérifiant des champs dans une table d'une
57base de données PostgresQL.
f430050e 58
b55a97e9
JR
59%description -l it.UTF-8
60Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
f430050e 61serviti da un server Web controllando i campi di una tabella in un
62database PostgresQL.
63
b55a97e9
JR
64%description -l ja.UTF-8
65Mod_auth_pgsql は、PostgresQL データベースのテーブルの中のフィールドを
66チェックすることによって、Web サーバーが提供する文書へのアクセスを
67制限できます。
f430050e 68
b55a97e9
JR
69%description -l pl.UTF-8
70To jest moduł uwierzytelnienia dla Apache pozwalający na
71uwierzytelnianie klientów HTTP z użyciem bazy danych PostgreSQL.
e289dd01 72
b55a97e9
JR
73%description -l pt_BR.UTF-8
74Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
f2ddec02 75PostgreSQL.
76
b55a97e9
JR
77%description -l sv.UTF-8
78Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
f430050e 79servade av en webbserver genom att kontrollera data i en
80PostgreSQL-databas.
81
82%prep
667576b5 83%setup -q -n mod_%{mod_name}-%{version}
2cc115fb
SZ
84
85%build
cb7cbee3 86%{apxs} \
667576b5 87 -I%{_includedir}/postgresql \
88 -lpq \
2cc115fb
SZ
89 -c mod_%{mod_name}.c \
90 -o mod_%{mod_name}.so
91
92%install
93rm -rf $RPM_BUILD_ROOT
bbe08d31 94install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
2cc115fb
SZ
95
96install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
97
bbe08d31
ER
98echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
99 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
100
e289dd01
JB
101%clean
102rm -rf $RPM_BUILD_ROOT
103
2cc115fb 104%post
c2268964 105%service -q apache restart
2cc115fb 106
b4e30a2e 107%postun
2cc115fb 108if [ "$1" = "0" ]; then
c2268964 109 %service -q apache restart
2cc115fb
SZ
110fi
111
bbe08d31
ER
112%triggerpostun -- apache1-mod_%{mod_name} < 0.9.12-1.1
113# check that they're not using old apache.conf
114if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
115 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
116fi
117
2cc115fb
SZ
118%files
119%defattr(644,root,root,755)
14388a92 120%doc *.html
f02bf43b 121%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
2cc115fb 122%attr(755,root,root) %{_pkglibdir}/*
This page took 0.040915 seconds and 4 git commands to generate.