]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blame - apache1-mod_auth_pgsql.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
CommitLineData
2cc115fb 1%define mod_name auth_pgsql
667576b5 2%define apxs /usr/sbin/apxs1
f430050e 3Summary: This is the PostgreSQL authentication module for Apache
8bbab28d
ER
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí PostgreSQL
5Summary(da.UTF-8): Autenticering for webtjeneren Apache fra en PostgreSQL-database
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7Summary(es.UTF-8): Autenticación vía PostgreSQL para Apache
8Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9Summary(it.UTF-8): Autenticazione di base per il server web Apache mediante un database PostgreSQL
10Summary(ja.UTF-8): PostgreSQL データベースを使った Apache Web サーバーへの基本認証
11Summary(nb.UTF-8): Autentisering for webtjeneren Apache fra en PostgreSQL-database
12Summary(pl.UTF-8): Moduł uwierzytelnienia PostgreSQL dla Apache
13Summary(pt_BR.UTF-8): Autenticação via PostgreSQL para o Apache
14Summary(sv.UTF-8): Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
667576b5 15Name: apache1-mod_%{mod_name}
ac317567 16Version: 0.9.12
f01493f7 17Release: 4
2cc115fb
SZ
18License: GPL
19Group: Networking/Daemons
2cc115fb 20Source0: http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
6386825e 21# Source0-md5: 7be403b7487c13cdb023cc526ee2e13a
21a4c8eb 22URL: http://www.giuseppetanzilli.it/mod_auth_pgsql/
6d8b33ad 23BuildRequires: apache1-devel >= 1.3.39
667576b5 24BuildRequires: postgresql-devel >= 7
c2268964 25BuildRequires: rpmbuild(macros) >= 1.268
bbe08d31 26Requires(triggerpostun): %{apxs}
f01493f7 27Requires: apache1(EAPI)
12b09ef4 28Obsoletes: apache-mod_auth_pgsql <= 0.9.12
2cc115fb
SZ
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
bbe08d31
ER
31%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
2cc115fb
SZ
33
34%description
35This is an authentication module for Apache that allows you to
3d064fe4 36authenticate HTTP clients using PostgreSQL RDBMS.
2cc115fb 37
b55a97e9
JR
38%description -l cs.UTF-8
39Balíček mod_auth_pgsql slouží pro omezení přístupu k dokumentům, které
40poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
f430050e 41PostgreSQL.
42
b55a97e9 43%description -l de.UTF-8
f430050e 44Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
b55a97e9
JR
45Web- Server bediente Dokumente zu beschränken, indem es die Felder in
46einer Tabelle in einer PostgresQL-Datenbank prüft.
f430050e 47
b55a97e9 48%description -l es.UTF-8
f430050e 49Mod_auth_pgsql puede usarse para limitar el acceso a documentos
50servidos desde un servidor web verificando datos en una base de datos
51PostgreSQL.
52
b55a97e9
JR
53%description -l fr.UTF-8
54mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
55servis par un serveur Web en vérifiant des champs dans une table d'une
56base de données PostgresQL.
f430050e 57
b55a97e9
JR
58%description -l it.UTF-8
59Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
f430050e 60serviti da un server Web controllando i campi di una tabella in un
61database PostgresQL.
62
b55a97e9
JR
63%description -l ja.UTF-8
64Mod_auth_pgsql は、PostgresQL データベースのテーブルの中のフィールドを
65チェックすることによって、Web サーバーが提供する文書へのアクセスを
66制限できます。
f430050e 67
b55a97e9
JR
68%description -l pl.UTF-8
69To jest moduł uwierzytelnienia dla Apache pozwalający na
70uwierzytelnianie klientów HTTP z użyciem bazy danych PostgreSQL.
e289dd01 71
b55a97e9
JR
72%description -l pt_BR.UTF-8
73Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
f2ddec02 74PostgreSQL.
75
b55a97e9
JR
76%description -l sv.UTF-8
77Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
f430050e 78servade av en webbserver genom att kontrollera data i en
79PostgreSQL-databas.
80
81%prep
667576b5 82%setup -q -n mod_%{mod_name}-%{version}
2cc115fb
SZ
83
84%build
cb7cbee3 85%{apxs} \
667576b5 86 -I%{_includedir}/postgresql \
87 -lpq \
2cc115fb
SZ
88 -c mod_%{mod_name}.c \
89 -o mod_%{mod_name}.so
90
91%install
92rm -rf $RPM_BUILD_ROOT
bbe08d31 93install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
2cc115fb
SZ
94
95install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
96
bbe08d31
ER
97echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
98 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
99
e289dd01
JB
100%clean
101rm -rf $RPM_BUILD_ROOT
102
2cc115fb 103%post
c2268964 104%service -q apache restart
2cc115fb 105
b4e30a2e 106%postun
2cc115fb 107if [ "$1" = "0" ]; then
c2268964 108 %service -q apache restart
2cc115fb
SZ
109fi
110
bbe08d31
ER
111%triggerpostun -- apache1-mod_%{mod_name} < 0.9.12-1.1
112# check that they're not using old apache.conf
113if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
114 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
115fi
116
2cc115fb
SZ
117%files
118%defattr(644,root,root,755)
14388a92 119%doc *.html
f02bf43b 120%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
2cc115fb 121%attr(755,root,root) %{_pkglibdir}/*
This page took 0.075321 seconds and 4 git commands to generate.