]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/blobdiff - apache1-mod_auth_mysql.spec
- confdir enabled apache1 (no triggers as it wasn't on ftp)
[packages/apache1-mod_auth_mysql.git] / apache1-mod_auth_mysql.spec
index a27664de7e66f808de256d136f9ce1d6e16447fe..8f2f14cf0e41cf498a73aefb2d779f56bcef7562 100644 (file)
@@ -1,5 +1,7 @@
+# TODO
+# - doesn't build
 %define                mod_name        auth_mysql
-%define        apxs            /usr/sbin/apxs
+%define                apxs            /usr/sbin/apxs1
 Summary:       This is the MySQL authentication module for Apache
 Summary(cs):   Základní autentizace pro WWW server Apache pomocí MySQL
 Summary(da):   Autenticering for webtjeneren Apache fra en MySQL-database
@@ -8,30 +10,34 @@ Summary(es): Autenticaci
 Summary(fr):   Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
 Summary(it):   Autenticazione di base per il server Web Apache mediante un database MySQL
 Summary(ja):   MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
-Summary(no):   Autentisering for webtjeneren Apache fra en MySQL-database
-Summary(pl):   Modu³ autentykacji MySQL dla Apache
+Summary(nb):   Autentisering for webtjeneren Apache fra en MySQL-database
+Summary(pl):   Modu³ uwierzytelnienia MySQL dla Apache
 Summary(pt_BR):        Autenticação via MySQL para o Apache
 Summary(sv):   Grundläggande autenticering för webbservern Apache med en MySQL-databas
-Name:          apache-mod_%{mod_name}
-Version:       2.20a
-Release:       1
+Name:          apache1-mod_%{mod_name}
+Version:       2.20
+Release:       1.1
 License:       GPL
 Group:         Networking/Daemons
-Source0:       http://web.oyvax.com/src/mod_auth_mysql-%{version}.tar.gz
+Source0:       http://www.diegonet.com/support/mod_auth_mysql-%{version}.tar.gz
+# Source0-md5: 3e88c23aabf2089fc753b2631a938f53
 URL:           http://www.diegonet.com/support/mod_auth_mysql.shtml
+BuildRequires: apache1-devel >= 1.3.33-2
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: mysql-devel
 BuildRequires: %{apxs}
-BuildRequires: apache(EAPI)-devel
-Prereq:                %{_sbindir}/apxs
-Requires:      apache(EAPI)
-Requires:      apache-mod_auth
+Requires:      apache1 >= 1.3.33-2
+Requires:      apache1-mod_auth
+Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 This is an authentication module for Apache that allows you to
-authenticate HTTP clients using mysql RDBMS.
+authenticate HTTP clients using MySQL RDBMS.
 
 %description -l cs
 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
@@ -63,8 +69,8 @@ mod_auth_mysql 
 ¤¬¤Ç¤­¤Þ¤¹¡£
 
 %description -l pl
-To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
-klientów HTTP z u¿yciem bazy danych mysql.
+To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
+uwierzytelnianie klientów HTTP z u¿yciem bazy danych MySQL.
 
 %description -l pt_BR
 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
@@ -79,40 +85,41 @@ MySQL-databas.
 %setup -q -n mod_%{mod_name}-%{version}
 
 %build
-aclocal
-autoconf
+%{__aclocal}
+%{__autoconf}
 %configure \
        --with-apxs=%{apxs} \
        --with-mysql=%{_prefix}
 
-%{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so
+ln -sf config.h auth_mysql_config.h
+%{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
-gzip -9nf README* USAGE
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
+%doc README* USAGE
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.086145 seconds and 4 git commands to generate.