]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/blame - apache1-mod_auth_mysql.spec
- use apache1(EAPI) for runtime dep
[packages/apache1-mod_auth_mysql.git] / apache1-mod_auth_mysql.spec
CommitLineData
05aeed51 1%define mod_name auth_mysql
91f8cbe8 2%define apxs /usr/sbin/apxs1
8c52f13d 3Summary: This is the MySQL authentication module for Apache
d7c4eeff
ER
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí MySQL
5Summary(da.UTF-8): Autenticering for webtjeneren Apache fra en MySQL-database
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7Summary(es.UTF-8): Autenticación vía MySQL para Apache
8Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9Summary(it.UTF-8): Autenticazione di base per il server Web Apache mediante un database MySQL
10Summary(ja.UTF-8): MySQL データベースを使った Apache Web サーバーへの基本認証
11Summary(nb.UTF-8): Autentisering for webtjeneren Apache fra en MySQL-database
12Summary(pl.UTF-8): Moduł uwierzytelnienia MySQL dla Apache
13Summary(pt_BR.UTF-8): Autenticação via MySQL para o Apache
14Summary(sv.UTF-8): Grundläggande autenticering för webbservern Apache med en MySQL-databas
91f8cbe8 15Name: apache1-mod_%{mod_name}
16Version: 2.20
9a6d53c0 17Release: 1.4
05aeed51 18License: GPL
19Group: Networking/Daemons
91f8cbe8 20Source0: http://www.diegonet.com/support/mod_auth_mysql-%{version}.tar.gz
21# Source0-md5: 3e88c23aabf2089fc753b2631a938f53
ec1f15bf 22Patch0: %{name}-mysql-API.patch
ef127e21 23URL: http://www.diegonet.com/support/mod_auth_mysql.shtml
6645e904 24BuildRequires: apache1-devel >= 1.3.39
986f70ed
JB
25BuildRequires: autoconf
26BuildRequires: automake
4fda686f 27BuildRequires: mysql-devel
14027267 28BuildRequires: rpmbuild(macros) >= 1.268
9a6d53c0 29Requires: apache1(EAPI)
91f8cbe8 30Requires: apache1-mod_auth
d94fb293 31Obsoletes: apache-mod_auth_mysql <= 2.20
05aeed51 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
b861cc59
ER
34%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
35%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
05aeed51 36
37%description
38This is an authentication module for Apache that allows you to
be06e49d 39authenticate HTTP clients using MySQL RDBMS.
05aeed51 40
880b0fde
JR
41%description -l cs.UTF-8
42Balíček mod_auth_mysql slouží pro omezení přístupu k dokumentům, které
43poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
5ad76a49 44MySQL.
45
880b0fde 46%description -l de.UTF-8
5ad76a49 47mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
880b0fde
JR
48Web- Server bediente Dokumente zu beschränken, indem es die Daten in
49einer MySQL-Datenbank prüft.
5ad76a49 50
880b0fde 51%description -l es.UTF-8
5ad76a49 52mod_auth_mysql puede usarse para limitar el acceso a documentos
53servidos por un servidor web verificando datos en una base de datos
54MySQL.
55
880b0fde
JR
56%description -l fr.UTF-8
57mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
58servis par un serveur Web en vérifiant les données dans une base de
59données MySQL.
5ad76a49 60
880b0fde
JR
61%description -l it.UTF-8
62mod_auth_mysql può essere usato per limitare l'accesso a documenti
5ad76a49 63serviti da un server Web controllando i dati in un database MySQL.
64
880b0fde
JR
65%description -l ja.UTF-8
66mod_auth_mysql は、MySQL データベースのデータをチェックすること
67によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
68ができます。
8c6d3893 69
880b0fde
JR
70%description -l pl.UTF-8
71To jest moduł uwierzytelnienia dla Apache pozwalający na
72uwierzytelnianie klientów HTTP z użyciem bazy danych MySQL.
8c52f13d 73
880b0fde
JR
74%description -l pt_BR.UTF-8
75Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
8c6d3893 76MySQL.
77
880b0fde
JR
78%description -l sv.UTF-8
79mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
5ad76a49 80servade av en webbserver genom att kontrollera data i en
81MySQL-databas.
82
83%prep
ef127e21 84%setup -q -n mod_%{mod_name}-%{version}
ec1f15bf 85%patch0 -p1
05aeed51 86
87%build
986f70ed 88%{__aclocal}
ede424c7 89%{__autoconf}
323848e3 90%configure \
ef127e21 91 --with-apxs=%{apxs} \
92 --with-mysql=%{_prefix}
93
b861cc59 94ln -sf config.h auth_mysql_config.h
046f0cd2 95%{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
05aeed51 96
97%install
98rm -rf $RPM_BUILD_ROOT
b861cc59 99install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
05aeed51 100
101install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
102
b861cc59
ER
103echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
104 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
105
5a59bf93
JB
106%clean
107rm -rf $RPM_BUILD_ROOT
108
05aeed51 109%post
14027267 110%service -q apache restart
05aeed51 111
6dbdc807 112%postun
05aeed51 113if [ "$1" = "0" ]; then
14027267 114 %service -q apache restart
05aeed51 115fi
116
05aeed51 117%files
118%defattr(644,root,root,755)
862ecd57 119%doc README* USAGE
126db427 120%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
05aeed51 121%attr(755,root,root) %{_pkglibdir}/*
This page took 0.088502 seconds and 4 git commands to generate.