]> git.pld-linux.org Git - packages/apache1-mod_auth_checkpasswd.git/blame_incremental - apache1-mod_auth_checkpasswd.spec
- converted to UTF-8
[packages/apache1-mod_auth_checkpasswd.git] / apache1-mod_auth_checkpasswd.spec
... / ...
CommitLineData
1%define mod_name auth_checkpasswd
2%define apxs /usr/sbin/apxs1
3Summary: This is the CHECKPASSWD authentication module for Apache
4Summary(pl.UTF-8): To jest moduł Apache uwierzytelniający przez CHECKPASSWD
5Name: apache1-mod_%{mod_name}
6Version: 1.0
7Release: 3
8License: GPL
9Group: Networking/Daemons
10Source0: mod_%{mod_name}-%{version}.tar.gz
11# Source0-md5: 7f699981ada026656affe2e35409bdf2
12Patch0: %{name}-aplog.patch
13BuildRequires: %{apxs}
14BuildRequires: apache1-devel >= 1.3.33-2
15BuildRequires: rpmbuild(macros) >= 1.268
16Requires(triggerpostun): %{apxs}
17Requires: apache1(EAPI)
18Obsoletes: apache-mod_auth_checkpasswd <= 1.0
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
22%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
23
24%description
25This is an authentication module for Apache that uses an external
26application compatible with DJB's "checkpasswd". The application may
27be setuid, which gives you a possibility to verify passwords using
28regular /etc/shadow.
29
30%description -l pl.UTF-8
31To jest moduł uwierzytelniający dla Apache który wykorzystuje
32zewnętrzną aplikację kompatybilną z "checkpasswd" DJB. Aplikacja może
33być suidowana, co daje możliwość weryfikowania haseł wykorzystując
34zwykły plik /etc/shadow.
35
36%prep
37%setup -q -c -n "mod_%{mod_name}-%{version}"
38%patch0 -p1
39
40%build
41%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
42
43%install
44rm -rf $RPM_BUILD_ROOT
45install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
46
47install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
48
49echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
50 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%post
56%service -q apache restart
57
58%postun
59if [ "$1" = "0" ]; then
60 %service -q apache restart
61fi
62
63%triggerpostun -- apache1-mod_%{mod_name} < 1.0-1.1
64# check that they're not using old apache.conf
65if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
66 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
67fi
68
69%files
70%defattr(644,root,root,755)
71%doc README
72%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
73%attr(755,root,root) %{_pkglibdir}/*
This page took 0.280216 seconds and 4 git commands to generate.