]> git.pld-linux.org Git - packages/apache1-mod_auth_any.git/blob - apache1-mod_auth_any.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_auth_any.git] / apache1-mod_auth_any.spec
1 %define mod_name        auth_any
2 %define apxs    /usr/sbin/apxs1
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs.UTF-8):      Základní autentizace pro WWW server Apache pomocí shellových příkazů
5 Summary(da.UTF-8):      En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de.UTF-8):      Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr.UTF-8):      Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it.UTF-8):      Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(nb.UTF-8):      En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl.UTF-8):      Podstawowy moduł uwierzytelnienia dla Apache, używający poleceń powłoki
11 Summary(pt.UTF-8):      Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl.UTF-8):      Osnovna avtentikacija za spletni strežnik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv.UTF-8):      Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache1-mod_%{mod_name}
15 Version:        1.5
16 Release:        2
17 Epoch:          1
18 License:        BSD
19 Group:          Networking/Daemons
20 Source0:        http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}.tar.gz
21 # Source0-md5:  a78780db253dd2dc33138f8b644423d2
22 URL:            http://www.itlab.musc.edu/webNIS/mod_auth_any.html
23 BuildRequires:  apache1-devel >= 1.3.39
24 BuildRequires:  rpmbuild(macros) >= 1.268
25 Requires(triggerpostun):        %{apxs}
26 Requires:       apache1(EAPI)
27 Obsoletes:      apache-mod_auth_any <= 1:1.5
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
31 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
32
33 %description
34 This module allows you to use any command line program (such as
35 webNIS) to authenticate a user.
36
37 %description -l cs.UTF-8
38 Balíček mod_auth_any slouží pro omezení přístupu k dokumentům, které
39 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
40 jakéhokoliv příkazu (jeho návratovým kódem).
41
42 %description -l de.UTF-8
43 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
44 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
45 gegebenen arbiträren Befehls prüft.
46
47 %description -l es.UTF-8
48 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
49 desde un servidor web verificando el código de retorno de un comando
50 arbitrario especificado.
51
52 %description -l fr.UTF-8
53 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
54 servis par un serveur Web en vérifiant le code de retour d'une
55 commande spécifiée arbitraire.
56
57 %description -l it.UTF-8
58 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
59 serviti da un server Web controllando il codice di ritorno di un dato
60 comando arbitrario.
61
62 %description -l ja.UTF-8
63 Mod_auth_any は任意に指定されたコマンドの戻りコードをチェックすること
64 によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
65 ができます。
66
67 %description -l pl.UTF-8
68 Ten moduł pozwala na użycie dowolnego programu działającego z linii
69 poleceń (jak np. webNIS) do uwierzytelniania użytkownika.
70
71 %description -l sv.UTF-8
72 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
73 servade av en webbserver genom att kontrollera returkoden från ett
74 godtyckligt angivet kommando.
75
76 %prep
77 %setup -q -n mod_%{mod_name}
78
79 %build
80 %{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
85
86 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
87 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
88         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 %service -q apache restart
95
96 %postun
97 if [ "$1" = "0" ]; then
98         %service -q apache restart
99 fi
100
101 %triggerpostun -- apache1-mod_%{mod_name} < 1:1.4-1.1
102 # check that they're not using old apache.conf
103 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
104         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
105 fi
106
107 %files
108 %defattr(644,root,root,755)
109 %doc docs/*
110 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
111 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.06257 seconds and 3 git commands to generate.