]> git.pld-linux.org Git - packages/apache1-mod_auth_any.git/blame - apache1-mod_auth_any.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_auth_any.git] / apache1-mod_auth_any.spec
CommitLineData
7baf28c3 1%define mod_name auth_any
2%define apxs /usr/sbin/apxs1
fa915c0a 3Summary: Basic authentication for the Apache Web server using arbitrary shell commands
8fa8c4b3
ER
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí shellových příkazů
5Summary(da.UTF-8): En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8Summary(it.UTF-8): Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9Summary(nb.UTF-8): En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10Summary(pl.UTF-8): Podstawowy moduł uwierzytelnienia dla Apache, używający poleceń powłoki
11Summary(pt.UTF-8): Um módulo de autenticação de LDAP para o servidor Web Apache
12Summary(sl.UTF-8): Osnovna avtentikacija za spletni strežnik Apache, z uporabo poljubnih lupinskih ukazov
13Summary(sv.UTF-8): Grundläggande autentisering för webbservern Apache med valfria skalkommandon
7baf28c3 14Name: apache1-mod_%{mod_name}
3ea6bdc7 15Version: 1.5
5d640d07 16Release: 2
7baf28c3 17Epoch: 1
3c603230 18License: BSD
2cb4d35a 19Group: Networking/Daemons
7baf28c3 20Source0: http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}.tar.gz
3ea6bdc7 21# Source0-md5: a78780db253dd2dc33138f8b644423d2
7baf28c3 22URL: http://www.itlab.musc.edu/webNIS/mod_auth_any.html
db0e68ae 23BuildRequires: apache1-devel >= 1.3.39
9533ffd9 24BuildRequires: rpmbuild(macros) >= 1.268
d32efb92 25Requires(triggerpostun): %{apxs}
5d640d07 26Requires: apache1(EAPI)
9533ffd9 27Obsoletes: apache-mod_auth_any <= 1:1.5
2cb4d35a 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
d32efb92
ER
30%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
31%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
2cb4d35a 32
33%description
bc29d277
JB
34This module allows you to use any command line program (such as
35webNIS) to authenticate a user.
36
6bb4b356
JR
37%description -l cs.UTF-8
38Balíček mod_auth_any slouží pro omezení přístupu k dokumentům, které
39poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
40jakéhokoliv příkazu (jeho návratovým kódem).
fa915c0a 41
6bb4b356 42%description -l de.UTF-8
fa915c0a 43Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
6bb4b356
JR
44Server bediente Dokumente zu beschränken, indem es den Rückcode eines
45gegebenen arbiträren Befehls prüft.
fa915c0a 46
6bb4b356 47%description -l es.UTF-8
fa915c0a 48Mod_auth_any puede usarse para limitar el acceso a documentos servidos
6bb4b356 49desde un servidor web verificando el código de retorno de un comando
fa915c0a 50arbitrario especificado.
51
6bb4b356
JR
52%description -l fr.UTF-8
53Mod_auth_any peut être utilisé pour limiter l'accès à des documents
54servis par un serveur Web en vérifiant le code de retour d'une
55commande spécifiée arbitraire.
fa915c0a 56
6bb4b356
JR
57%description -l it.UTF-8
58Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
fa915c0a 59serviti da un server Web controllando il codice di ritorno di un dato
60comando arbitrario.
61
6bb4b356
JR
62%description -l ja.UTF-8
63Mod_auth_any は任意に指定されたコマンドの戻りコードをチェックすること
64によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
65ができます。
fa915c0a 66
6bb4b356
JR
67%description -l pl.UTF-8
68Ten moduł pozwala na użycie dowolnego programu działającego z linii
69poleceń (jak np. webNIS) do uwierzytelniania użytkownika.
2cb4d35a 70
6bb4b356
JR
71%description -l sv.UTF-8
72Mod_auth_any kan användas för att begränsa åtkomsten till dokument
73servade av en webbserver genom att kontrollera returkoden från ett
fa915c0a 74godtyckligt angivet kommando.
75
76%prep
7d35ef11 77%setup -q -n mod_%{mod_name}
6979abf2 78
2cb4d35a 79%build
c5543b7a 80%{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
2cb4d35a 81
82%install
83rm -rf $RPM_BUILD_ROOT
d32efb92 84install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
2cb4d35a 85
86install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
d32efb92
ER
87echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
88 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
bc29d277 89
bc29d277
JB
90%clean
91rm -rf $RPM_BUILD_ROOT
92
2cb4d35a 93%post
9533ffd9 94%service -q apache restart
2cb4d35a 95
c583b095 96%postun
2cb4d35a 97if [ "$1" = "0" ]; then
9533ffd9 98 %service -q apache restart
2cb4d35a 99fi
100
d32efb92
ER
101%triggerpostun -- apache1-mod_%{mod_name} < 1:1.4-1.1
102# check that they're not using old apache.conf
103if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
104 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
105fi
106
2cb4d35a 107%files
108%defattr(644,root,root,755)
ed51419d 109%doc docs/*
61b24664 110%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
2cb4d35a 111%attr(755,root,root) %{_pkglibdir}/*
This page took 0.083171 seconds and 4 git commands to generate.