]> git.pld-linux.org Git - packages/apache1-mod_antihak.git/blame_incremental - apache1-mod_antihak.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_antihak.git] / apache1-mod_antihak.spec
... / ...
CommitLineData
1%define apxs /usr/sbin/apxs1
2%define mod_name antihak
3%define tar_ver 0.3.1-beta
4Summary: Antihak module for Apache
5Summary(pl.UTF-8): Moduł antihak dla Apache
6Name: apache1-mod_%{mod_name}
7Version: 0.3.1beta
8Release: 3.3
9License: GPL
10Group: Networking/Daemons
11Source0: http://dl.sourceforge.net/apantihak/mod_antihak-%{tar_ver}.tar.gz
12# Source0-md5: 38f22f5b5662e8dd7318c42fa96fb083
13Patch0: %{name}-iptables.patch
14Patch1: %{name}-am.patch
15Patch2: %{name}-mysql-API.patch
16URL: http://sourceforge.net/projects/apantihak/
17BuildRequires: apache1-devel >= 1.3.39
18BuildRequires: autoconf
19BuildRequires: automake
20BuildRequires: libtool
21BuildRequires: mysql-devel
22BuildRequires: rpmbuild(macros) >= 1.268
23Requires(post,preun): grep
24Requires(preun): sed >= 4.0
25Requires: apache1 >= 1.3.33-2
26Requires: iptables
27Requires: sudo
28Obsoletes: apache-mod_antihak <= 0.3.1beta
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
33
34%description
35mod_antihak is an Apache Module designed to eliminate the CodeRed and
36Nimda worm's network bandwidth consumption. We're working to make it
37as easy as writing a line of text to add more worms! :)
38
39%description -l pl.UTF-8
40mod_antihak to moduł Apache służący do eliminowania zapychania sieci
41przez robaki CodeRed i Nimda. Ponadto trwają prace nad umożliwieniem
42łatwego dodawania obsługi kolejnych robaków.
43
44%prep
45%setup -q -n mod_antihak-0.3.1-beta/src
46%patch0 -p0
47%patch1 -p0
48%patch2 -p1
49
50%build
51rm -f tools/missing
52%{__libtoolize}
53%{__aclocal}
54%{__autoconf}
55%{__automake}
56
57%configure \
58 CC="%{__cc}" \
59 CFLAGS="%{rpmcflags} -I/usr/include/mysql" \
60 APACHE_APXS=%{apxs} \
61 --with-mysql
62
63%{__make}
64
65%install
66rm -rf $RPM_BUILD_ROOT
67install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
68
69install mod_antihak/mod_antihak.so $RPM_BUILD_ROOT%{_pkglibdir}
70echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
71 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77if ! grep -qF "http ALL= NOPASSWD: /sbin/iptables" ; then
78 echo "#http ALL= NOPASSWD: /sbin/iptables" >> /etc/sudoers
79 echo "%{mod_name}: You need to allow apache to run iptables as root,"
80 echo "%{mod_name}: appropriate (commented out) line added to /etc/sudoers;"
81 echo "%{mod_name}: be sure to uncomment it if you want this module to work."
82fi
83%service -q apache restart
84
85%postun
86if [ "$1" = "0" ]; then
87 if grep -qF "^http ALL= NOPASSWD: /sbin/iptables" /etc/sudoers ; then
88 sed -i -e '/^http ALL= NOPASSWD: /sbin/iptables$/d' /etc/sudoers
89 fi
90 %service -q apache restart
91fi
92
93%files
94%defattr(644,root,root,755)
95%doc AUTHORS INSTALL ChangeLog NEWS TODO
96%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
97%attr(755,root,root) %{_pkglibdir}/*
This page took 0.054915 seconds and 4 git commands to generate.