]> git.pld-linux.org Git - packages/apache.git/commitdiff
tabs
authorElan Ruusamäe <glen@delfi.ee>
Thu, 27 Feb 2014 17:29:19 +0000 (19:29 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 27 Feb 2014 17:29:19 +0000 (19:29 +0200)
apache.spec

index f85c7176775f25e4662c49131eacce693b55b123..d0c4413e4e20d1f754ee93579cdbda669a52215f 100644 (file)
@@ -2952,14 +2952,16 @@ if [ ! -L /etc/httpd/httpd.conf ]; then
        install -d /etc/httpd
        ln -s conf.d /etc/httpd/httpd.conf
 fi
+
+# handle $HTTPD_MPM from sysconfig
 if [ -f /etc/sysconfig/httpd ]; then
-        MPM=$(grep ^HTTPD_MPM /etc/sysconfig/httpd |sed 's,HTTPD_MPM=,,;s,",,g')
-        if [ -n "$MPM" ]; then
-                echo "LoadModule mpm_${MPM}_module                modules/mod_mpm_${MPM}.so" > /etc/httpd/conf.d/10_mpm.conf.rpmnew
-                cat /etc/httpd/conf.d/10_mpm.conf >> /etc/httpd/conf.d/10_mpm.conf.rpmnew
-                mv /etc/httpd/conf.d/10_mpm.conf.rpmnew /etc/httpd/conf.d/10_mpm.conf
-                sed -i -e 's,HTTPD_MPM.*,,g' /etc/sysconfig/httpd
-        fi
+       MPM=$(grep ^HTTPD_MPM /etc/sysconfig/httpd | sed 's,HTTPD_MPM=,,;s,",,g')
+       if [ -n "$MPM" ]; then
+               echo "LoadModule mpm_${MPM}_module      modules/mod_mpm_${MPM}.so" > /etc/httpd/conf.d/10_mpm.conf.rpmnew
+               cat /etc/httpd/conf.d/10_mpm.conf >> /etc/httpd/conf.d/10_mpm.conf.rpmnew
+               mv -f /etc/httpd/conf.d/10_mpm.conf.rpmnew /etc/httpd/conf.d/10_mpm.conf
+               sed -i -e 's,HTTPD_MPM.*,,g' /etc/sysconfig/httpd
+       fi
 fi
 
 exit 0
This page took 0.041951 seconds and 4 git commands to generate.