]> git.pld-linux.org Git - packages/apache.git/commitdiff
- rel 8; fix graceful restart for keepalive connections auto/ac/apache-2_2_17-8 auto/th/apache-2_2_17-8 auto/ti/apache-2_2_17-8
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 13 Feb 2011 18:53:04 +0000 (18:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-bug-41743.patch -> 1.1
    apache.spec -> 1.615

apache-bug-41743.patch [new file with mode: 0644]
apache.spec

diff --git a/apache-bug-41743.patch b/apache-bug-41743.patch
new file mode 100644 (file)
index 0000000..476e953
--- /dev/null
@@ -0,0 +1,42 @@
+Index: server/mpm/prefork/prefork.c
+===================================================================
+--- server/mpm/prefork/prefork.c       (wersja 1069427)
++++ server/mpm/prefork/prefork.c       (wersja 1069428)
+@@ -330,6 +330,7 @@
+ static void stop_listening(int sig)
+ {
++    mpm_state = AP_MPMQ_STOPPING;
+     ap_close_listeners();
+     /* For a graceful stop, we want the child to exit when done */
+@@ -350,6 +351,7 @@
+          */
+         return;
+     }
++    mpm_state = AP_MPMQ_STOPPING;
+     shutdown_pending = 1;
+     is_graceful = (sig == AP_SIG_GRACEFUL_STOP);
+ }
+@@ -363,6 +365,7 @@
+         /* Probably not an error - don't bother reporting it */
+         return;
+     }
++    mpm_state = AP_MPMQ_STOPPING;
+     restart_pending = 1;
+     is_graceful = (sig == AP_SIG_GRACEFUL);
+ }
+@@ -458,8 +461,10 @@
+ int ap_graceful_stop_signalled(void)
+ {
+-    /* not ever called anymore... */
+-    return 0;
++    /* Return true if the server is stopping for whatever reason; the
++     * function is used to initiate a fast exit from the connection
++     * processing loop. */
++    return mpm_state == AP_MPMQ_STOPPING;
+ }
+
index 42b99242023e5afb4315fa881d4f14e86e84ee80..3de6d9b2a15c048d6ab485af162b51d39e729ceb 100644 (file)
@@ -41,7 +41,7 @@ Summary(ru.UTF-8):    Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
 Version:       2.2.17
-Release:       7
+Release:       8
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
@@ -97,6 +97,7 @@ Patch24:      %{name}-bug-48094.patch
 # http://scripts.mit.edu/trac/browser/trunk/server/common/patches/httpd-2.2.x-mod_ssl-sessioncaching.patch?rev=1348
 Patch25:       httpd-2.2.x-mod_ssl-sessioncaching.patch
 Patch26:       apache-mod_vhost_alias_docroot.patch
+Patch27:       apache-bug-41743.patch
 URL:           http://httpd.apache.org/
 BuildRequires: apr-devel >= 1:1.2
 BuildRequires: apr-util-devel >= 1:1.3
@@ -1786,6 +1787,7 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch24 -p1
 %patch25 -p1
 %patch26 -p1
+%patch27 -p0
 
 # using system apr, apr-util and pcre
 rm -rf srclib/{apr,apr-util,pcre}
This page took 0.25489 seconds and 4 git commands to generate.