]> git.pld-linux.org Git - packages/apache-php-fcgi.git/blob - apache-php-fcgi.spec
requires mod_actions
[packages/apache-php-fcgi.git] / apache-php-fcgi.spec
1 %define         apxs    /usr/sbin/apxs
2 Summary:        Support for the PHP via FastCGI protocol for Apache webserver
3 Name:           apache-php-fcgi
4 Version:        5.6
5 Release:        2
6 License:        GPL
7 Group:          Applications/WWW
8 Source0:        apache.conf
9 BuildRequires:  apache-devel >= 1.3.39
10 BuildRequires:  rpmbuild(macros) >= 1.268
11 Requires:       apache-mod_actions
12 Requires:       apache-mod_fastcgi
13 Requires:       php(fcgi)
14 Suggests:       php-fcgi-init
15 Provides:       webserver(php) = %{version}
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
20
21 %description
22 This virtual package provides support for the PHP via FastCGI
23 protocol.
24
25 %prep
26 %setup -qcT
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
31 cp -p %{SOURCE0} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_php-fcgi.conf
32
33 %clean
34 rm -rf $RPM_BUILD_ROOT
35
36 %post
37 %service -q httpd restart
38
39 %postun
40 if [ "$1" = "0" ]; then
41         %service -q httpd restart
42 fi
43
44 %files
45 %defattr(644,root,root,755)
46 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_php-fcgi.conf
This page took 0.063926 seconds and 3 git commands to generate.