]> git.pld-linux.org Git - packages/apache-mod_xslt2.git/blame - apache-mod_xslt2.spec
- updated to 1.4.1
[packages/apache-mod_xslt2.git] / apache-mod_xslt2.spec
CommitLineData
2bf23fdd
ER
1# TODO
2# - update to current apr, apu
760de7a1 3%define mod_name xslt
c733ba18 4%define apxs /usr/sbin/apxs
a8a5089e 5%define snap 337e290
760de7a1 6Summary: Module to serve XML based content
1ed018ea 7Summary(pl.UTF-8): Moduł do udostępniania dokumentów XML
760de7a1 8Name: apache-mod_%{mod_name}2
a8a5089e
AG
9Version: 1.4.1
10Release: 0.1
760de7a1 11License: GPL
932d32c9 12Group: Networking/Daemons/HTTP
a8a5089e
AG
13Source0: https://github.com/ccontavalli/mod-xslt/tarball/v1.4.1#/%{name}-%{version}.tar.gz
14# Source0-md5: 71cbec1d497a3264633cc50dccc6c7a3
760de7a1 15Source1: %{name}.conf
16Patch0: %{name}-makefile.patch
17URL: http://www.mod-xslt2.com/
4281ca40 18BuildRequires: %{apxs}
2bf23fdd 19BuildRequires: apache-devel >= 2.0
014f176b 20BuildRequires: libxslt-devel
d913c531 21BuildRequires: pcre-devel
d10d39a3 22BuildRequires: rpmbuild(macros) >= 1.268
ab91a250 23Requires(post,postun): /sbin/ldconfig
2bf23fdd 24Requires: apache(modules-api) = %apache_modules_api
2bf23fdd 25Conflicts: apache-mod_xslt
760de7a1 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
2bf23fdd 28%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
c746243b 29%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
760de7a1 30
31%description
32mod_xslt is a simple Apache module to serve XML based content. Data is
33stored in XML files on the server. The user requests the XML file and
34the translation method via a url such as this:
35http://localhost/sourcefile.html. The module will parse this URL into
36a XML source file and an XSL source file. In the example above, the
37XML file will be sourcefile.xml. The module will open sourcefile.xml
38and determine its DOCTYPE. Based on the DOCTYPE, the XSL file will be
39opened. Should the DOCTYPE be "tutorial", the XSL file opened would be
40tutorial_html.xsl. The content-type returned to the browser is
41text/html. The translation occurs transparently to the user.
42
5aeb65b3
JR
43%description -l pl.UTF-8
44mod_xslt jest prostym modułem Apache do udostępniania dokumentów XML.
45Dane są zapisane w plikach XML na serwerze. Użytkownik żąda pliku XML
46i tłumaczenia poprzez URL w stylu http://localhost/sourcefile.html.
47Moduł zamienia ten URL na pliki źródłowe XML i XSL. W tym przykładzie
48plikiem XML będzie sourcefile.xml. Moduł otworzy plik sourcefile.xml i
49określi DOCTYPE, na podstawie którego otworzy odpowiedni plik XSL.
50Jeżeli DOCTYPE jest "tutorial", plikiem XSL będzie tutorial_html.xsl.
51Następnie moduł dokona przetwarzania pliku XML za pomocą arkusza XSLT
52i zwróci przeglądarce powstały w ten sposób text/html. Cały proces
53odbywa się w sposób niewidoczny dla użytkownika.
760de7a1 54
55%package devel
d913c531 56Summary: Development headers for mod_xslt2
1ed018ea 57Summary(pl.UTF-8): Pliki nagłówkowe mod_xslt2
d913c531
JB
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
760de7a1 60
61%description devel
62development headers for mod_xslt2.
63
64%package static
d913c531 65Summary: Static mod_xslt2 library
1ed018ea 66Summary(pl.UTF-8): Statyczna biblioteka mod_xslt2
d913c531
JB
67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
760de7a1 69
70%description static
d913c531
JB
71Static mod_xslt2 library.
72
5aeb65b3 73%description static -l pl.UTF-8
d913c531 74Statyczna biblioteka mod_xslt2.
760de7a1 75
76%prep
a8a5089e 77%setup -q -n ccontavalli-mod-xslt-%{snap}
760de7a1 78%patch0 -p1
79
80%build
2bf23fdd 81%configure \
a8a5089e 82 --with-sapi=apache2 \
2bf23fdd 83 --with-apr-config=%{_bindir}/apr-1-config \
a8a5089e 84 --with-apu-config=%{_bindir}/apu-1-config \
2bf23fdd
ER
85 --with-apxs=%{apxs}
86%{__make}
760de7a1 87
88%install
89rm -rf $RPM_BUILD_ROOT
c746243b 90install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
760de7a1 91
a8a5089e 92%{__make} -j1 install \
d913c531 93 DESTDIR=$RPM_BUILD_ROOT
760de7a1 94
c746243b 95install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/70_mod_%{mod_name}.conf
760de7a1 96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post
d913c531 101/sbin/ldconfig
d10d39a3 102%service -q httpd restart
760de7a1 103
e7a28ea6 104%postun
ab91a250 105/sbin/ldconfig
760de7a1 106if [ "$1" = "0" ]; then
d10d39a3 107 %service -q httpd restart
760de7a1 108fi
d913c531 109
760de7a1 110%files
111%defattr(644,root,root,755)
c746243b 112%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
2bf23fdd 113%attr(755,root,root) %{_pkglibdir}/*.so
a8a5089e
AG
114%attr(755,root,root) %{_libdir}/libmodxslt1.so.*.*.*
115%{_mandir}/man1/modxslt-config.1*
116%{_mandir}/man1/modxslt-parse.1*
117%{_mandir}/man1/modxslt-perror.1*
760de7a1 118
119%files devel
d913c531
JB
120%defattr(644,root,root,755)
121%attr(755,root,root) %{_bindir}/*
760de7a1 122%{_libdir}/*.la
a8a5089e 123%{_includedir}/modxslt1
760de7a1 124
125%files static
d913c531 126%defattr(644,root,root,755)
760de7a1 127%{_libdir}/*.a
This page took 0.081032 seconds and 4 git commands to generate.