]> git.pld-linux.org Git - packages/apache-mod_whois.git/commitdiff
- rel.4 - epp_server patch, taken from epp-server sources. master auto/th/apache-mod_whois-0.1-4
authorPaweł Gołaszewski <blues@pld-linux.org>
Mon, 28 Sep 2015 08:19:45 +0000 (10:19 +0200)
committerPaweł Gołaszewski <blues@pld-linux.org>
Mon, 28 Sep 2015 08:19:45 +0000 (10:19 +0200)
Makes that module working and prevent crashing.

apache-mod_whois-epp_server.patch [new file with mode: 0644]
apache-mod_whois.spec

diff --git a/apache-mod_whois-epp_server.patch b/apache-mod_whois-epp_server.patch
new file mode 100644 (file)
index 0000000..8138055
--- /dev/null
@@ -0,0 +1,25 @@
+--- ./mod_whois.c.org  2015-09-28 10:14:20.053113205 +0200
++++ ./mod_whois.c      2015-09-28 10:16:24.859605173 +0200
+@@ -31,7 +31,7 @@ module AP_MODULE_DECLARE_DATA whois_modu
+ typedef struct whois_conn_rec {
+         int whois_on;
+-        char *whois_prefix;
++        const char *whois_prefix;
+ } whois_conn_rec;
+@@ -69,7 +69,7 @@ apr_status_t whois_input_filter(ap_filte
+       const char *original;
+       char *quoted;
+       char *crlfpos;
+-      int len;
++      apr_size_t len;
+       
+       if (mode != AP_MODE_GETLINE) {
+               return ap_get_brigade(f->next, b, mode, block, readbytes);
+@@ -163,4 +163,3 @@ module AP_MODULE_DECLARE_DATA whois_modu
+       whois_cmds,
+       register_hooks
+ };
+-
index 728307e909703999aae32c913a04b6e5ed451968..8f02f0c8bae7d33d4134c923f834e1ad0bbf3146 100644 (file)
@@ -4,12 +4,13 @@ Summary:      Apache module: WHOIS->WEB gateway
 Summary(pl.UTF-8):     Moduł Apache'a: bramka WHOIS->WWW
 Name:          apache-mod_%{mod_name}
 Version:       0.1
-Release:       3
+Release:       4
 License:       distributable
 Group:         Networking/Daemons/HTTP
 Source0:       http://dl.sourceforge.net/modwhois/mod_%{mod_name}-%{version}.tar.gz
 # Source0-md5: 8b4f29868c221b2d54f59b7a0c090698
 Source1:       %{name}.conf
+Patch0:                %{name}-epp_server.patch
 URL:           http://modwhois.sourceforge.net/
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.0
@@ -28,6 +29,7 @@ Moduł Apache'a: bramka WHOIS->WWW.
 
 %prep
 %setup -q -n mod_%{mod_name}
+%patch0 -p1
 
 %build
 %{apxs} -c mod_%{mod_name}.c
This page took 0.05564 seconds and 4 git commands to generate.