]> git.pld-linux.org Git - packages/apache-mod_whatkilledus.git/commitdiff
- initial
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 14 Jun 2008 17:58:54 +0000 (17:58 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-mod_whatkilledus.spec -> 1.7

apache-mod_whatkilledus.spec

index a4efe97cb3a3fd7d2bac2de489bf007aad99e849..5ea204ca9503974e892cdaffd5ab9a03f9832bd9 100644 (file)
@@ -1,46 +1,54 @@
 %define                mod_name        whatkilledus
 %define        apxs            /usr/sbin/apxs
-Summary:       Knows what a thread was handling in case the thread segfaults
-Summary(pl.UTF-8):     Moduł wiedzący, co obsługiwał wątek w przypadku naruszenia ochrony pamięci
+Summary:       Apache module: logs request when child process crashes
 Name:          apache-mod_%{mod_name}
-Version:       1.0
-Release:       1
-License:       Apache
+Version:       0.1
+Release:       0.20040323.1
+License:       Apache v2.0
 Group:         Networking/Daemons
 Source0:       http://people.apache.org/~trawick/mod_whatkilledus.c
 # Source0-md5: e59c5d56e294a31e5b158ad5e4553001
-URL:           http://people.apache.org/~trawick/exception_hook.html
-BuildRequires: apache-devel >= 2.0.43
+Source1:       http://mirrors.ludost.net/gentoo-portage/www-apache/mod_whatkilledus/files/gen_test_char.c
+# Source1-md5: 7c4e734d1afc695a5be53581998f3700
+BuildRequires: %{apxs}
+BuildRequires: apache-devel >= 2.0
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      apache(modules-api) = %apache_modules_api
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 %define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+%define                _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
 
 %description
-Keeps a little bit of state on each active connection, which allows it
-to know what a thread was handling in case the thread segfaults.
-
-%description -l pl.UTF-8
-Moduł przechowujący wybrane informacje o stanie każdego aktywnego
-połączenia, pozwalające dowiedzieć się, co obsługiwał wątek w
-sytuacji, kiedy spowodował naruszenie ochrony pamięci.
+mod_whatkilledus is an experimental module for Apache httpd 2.x which
+tracks the current request and logs a report of the active request
+when a child process crashes. You should verify that it works
+reasonably on your system before putting it in production.
 
 %prep
 %setup -q -c -T
+install %{SOURCE0} .
 
 %build
-%{apxs} -c %{SOURCE0}
+%{__cc} `%{_bindir}/apr-1-config --includes --cppflags` %{SOURCE1} -o gen_test_char
+./gen_test_char > test_char.h
+%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf,/var/log/httpd}
+install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
-libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
+touch $RPM_BUILD_ROOT/var/log/httpd/whatkilledus_log
 
-echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' \
-       > $RPM_BUILD_ROOT/etc/httpd/httpd.conf/68_mod_%{mod_name}.conf
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf << 'EOF'
+LoadModule %{mod_name}_module modules/mod_%{mod_name}.so
+<IfModule mod_%{mod_name}.c>
+EnableExceptionHook On
+whatkilledus_log /var/log/httpd/error.log
+</IfModule>
+EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -55,5 +63,5 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*mod_*.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.115568 seconds and 4 git commands to generate.