]> git.pld-linux.org Git - packages/apache-mod_vhost_limit.git/commitdiff
- new
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 13 Feb 2004 16:19:25 +0000 (16:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-mod_vhost_limit.spec -> 1.1

apache-mod_vhost_limit.spec [new file with mode: 0644]

diff --git a/apache-mod_vhost_limit.spec b/apache-mod_vhost_limit.spec
new file mode 100644 (file)
index 0000000..a988f7f
--- /dev/null
@@ -0,0 +1,59 @@
+%define                mod_name        vhost_limit
+%define        apxs            /usr/sbin/apxs
+Summary:       Apache module: vhost_limit limits
+Summary(pl):   Modu³ do apache: limity pasma
+Name:          apache-mod_%{mod_name}
+Version:       0.4
+Release:       1
+License:       Apache
+Group:         Networking/Daemons
+Source0:       http://www.nowhere-land.org/programs/mod_vhost_limit/mod_%{mod_name}-%{version}.tar.gz
+URL:           http://www.nowhere-land.org/programs/mod_vhost_limit/
+BuildRequires: apache(EAPI)-devel
+Requires(post,preun):  %{apxs}
+Requires(post,preun):  grep
+Requires(preun):       fileutils
+Requires:      apache(EAPI)
+Requires:      crondaemon
+Requires:      procps
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define         _sysconfdir     /etc/httpd
+
+%description
+This is the module for Apache Web Server to restrict the number of simultaneous connections per a virtual host.
+
+%prep
+%setup -q -n mod_%{mod_name}-%{version}
+
+%build
+%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
+
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+if [ -f /var/lock/subsys/httpd ]; then
+       /etc/rc.d/init.d/httpd restart 1>&2
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc */*html
+%attr(755,root,root) %{_pkglibdir}/*
This page took 0.076258 seconds and 4 git commands to generate.