]> git.pld-linux.org Git - packages/apache-mod_vhost_limit.git/blob - apache-mod_vhost_limit.spec
- md5
[packages/apache-mod_vhost_limit.git] / apache-mod_vhost_limit.spec
1 %define         mod_name        vhost_limit
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: vhost_limit limits
4 Summary(pl):    Modu³ do apache: limity pasma dla serwerów wirtualnych
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4
7 Release:        1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://www.nowhere-land.org/programs/mod_vhost_limit/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  bae36a7174e184804b91356ef67d0b5d
12 URL:            http://www.nowhere-land.org/programs/mod_vhost_limit/
13 BuildRequires:  apache(EAPI)-devel
14 Requires(post,preun):   %{apxs}
15 Requires(post,preun):   grep
16 Requires(preun):        fileutils
17 Requires:       apache(EAPI)
18 Requires:       crondaemon
19 Requires:       procps
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
23 %define         _sysconfdir     /etc/httpd
24
25 %description
26 This is the module for Apache Web Server to restrict the number of
27 simultaneous connections per a virtual host.
28
29 %description -l pl
30 Ten pakiet zawiera modu³ dla serwera WWW Apache s³u¿±cy do
31 ograniczania liczby jednoczesnych po³±czeñ dla serwerów wirtualnych.
32
33 %prep
34 %setup -q -n mod_%{mod_name}-%{version}
35
36 %build
37 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
42
43 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
50 if [ -f /var/lock/subsys/httpd ]; then
51         /etc/rc.d/init.d/httpd restart 1>&2
52 fi
53
54 %preun
55 if [ "$1" = "0" ]; then
56         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
57         if [ -f /var/lock/subsys/httpd ]; then
58                 /etc/rc.d/init.d/httpd restart 1>&2
59         fi
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc */*html
65 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.072198 seconds and 4 git commands to generate.