]> git.pld-linux.org Git - packages/apache-mod_transform.git/blob - apache-mod_transform.spec
- fix config dir
[packages/apache-mod_transform.git] / apache-mod_transform.spec
1 %define         mod_name        transform
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to serve XML based content
4 Summary(pl.UTF-8):      Moduł do udostępniania dokumentów XML
5 Name:           apache-mod_%{mod_name}
6 Version:        0.6.0
7 Release:        1
8 License:        GPL v2+
9 Group:          Networking/Daemons/HTTP
10 Source0:        http://www.outoforder.cc/downloads/mod_transform/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  8b27adea2536f105470b4bedc418ab3b
12 Source1:        %{name}.conf
13 URL:            http://www.outoforder.cc/projects/apache/mod_transform/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apr-devel >= 1:1.0.0
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRequires:  libxml2-devel
20 BuildRequires:  libxslt-devel
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 BuildRequires:  sed >= 4.0
23 Requires:       apache(modules-api) = %apache_modules_api
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
28
29 %description
30 mod_transform is a filter module that allows Apache 2.0 to do dynamic
31 XSL Transformations on either static XML documents, or XML documents
32 generated from another Apache module or CGI program.
33
34 %description -l pl.UTF-8
35 mod_transform to moduł filtra umożliwiający serwerowi Apache 2.0
36 wykonywać dynamiczne przekształcenia XML na statycznych dokumentach
37 XML lub dokumentach XML generowanych przez inny moduł Apache'a lub
38 program CGI.
39
40 %prep
41 %setup -q -n mod_%{mod_name}-%{version}
42 sed -i -e "s:apr-config:apr-1-config:g" aclocal.m4 m4/apache.m4
43 sed -i -e "s:apu-config:apu-1-config:g" aclocal.m4 m4/apache.m4
44
45 %build
46 %{__libtoolize}
47 %{__aclocal} -I m4
48 %{__autoconf}
49 %{__autoheader}
50 %{__automake}
51 %configure
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
57
58 install -p src/.libs/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
59 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/61_mod_transform.conf
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %service -q httpd restart
66
67 %postun
68 if [ "$1" = "0" ]; then
69         %service -q httpd restart
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc TODO
75 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
76 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.070046 seconds and 3 git commands to generate.