]> git.pld-linux.org Git - packages/apache-mod_suphp.git/blobdiff - apache-mod_suphp.spec
- apr update; untested
[packages/apache-mod_suphp.git] / apache-mod_suphp.spec
index 551fdb25e2deca1bb9c9ad824f9640c78793313d..cd8c3a3a765e49b415216235ab6e8af7e6f76619 100644 (file)
@@ -1,21 +1,33 @@
+#
+# Available build options:
+%bcond_with    checkpath       # enable check if php execution is within
+                               # DOCUMENT_ROOT of the vhost
+#
 %define                mod_name        suphp
 %define        apxs            /usr/sbin/apxs
 Summary:       Apache module: suPHP - execute PHP scripts with the permissions of their owners
 Summary(pl):   Modu³ do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich w³a¶cicieli
 Name:          apache-mod_%{mod_name}
-Version:       0.3
-Release:       0.1
+Version:       0.5.2
+Release:       3
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz     
-# Source0-md5: f80d54de6aff5db4ab76670f1c5b3c6d
+# Source0-md5: 337909e87027af124052baddddbd2994
+Source1:       %{name}.logrotate
+Source2:       %{name}.conf
+Patch0:                %{name}-apr.patch
 URL:           http://www.suphp.org/
 BuildRequires: %{apxs}
-BuildRequires: apache-devel <= 1.4
+BuildRequires: apache-devel >= 2
+BuildRequires: autoconf
+BuildRequires: automake
 Requires(post,preun):  %{apxs}
-Requires:      apache
+Requires:      apache >= 2
+Requires:      php-cgi
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
@@ -32,21 +44,36 @@ modu
 
 %prep
 %setup -q -n %{mod_name}-%{version}
+%patch0 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
-%configure
-%{__make}
+chmod 755 configure
+%configure \
+       %{?with_checkpath: --enable-checkpath} \
+       %{!?with_checkpath: --disable-checkpath} \
+       --with-apache-user=http \
+       --with-min-uid=500 \
+       --with-min-gid=1000 \
+       --with-apxs=%{apxs} \
+       --disable-checkuid \
+       --disable-checkgid 
 
-#%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir}}
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+
+install src/suphp $RPM_BUILD_ROOT%{_sbindir}
+install src/apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod-suphp.conf
 
-install src/apache/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT/etc/logrotate.d
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -68,4 +95,7 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc README AUTHORS ChangeLog doc
+%attr(4755,root,root) %{_sbindir}/suphp
 %attr(755,root,root) %{_pkglibdir}/*
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*
This page took 0.126999 seconds and 4 git commands to generate.