]> git.pld-linux.org Git - packages/apache-mod_suphp.git/blobdiff - apache-mod_suphp.spec
- BR s@%{apxs}@apache-apxs@g
[packages/apache-mod_suphp.git] / apache-mod_suphp.spec
index b2f3edf39294b83b13c63540fe8b627d9c0d59fe..a69787bfe8bc1796ed50614ec1d5f75d93b5ccae 100644 (file)
@@ -1,56 +1,62 @@
 #
 # Available build options:
-%bcond_with    checkpath       # enable check if php execution is within
-                               # DOCUMENT_ROOT of the vhost
+%bcond_with    checkpath       # enable check if php execution is within DOCUMENT_ROOT of the vhost
 #
 %define                mod_name        suphp
 %define        apxs            /usr/sbin/apxs
 Summary:       Apache module: suPHP - execute PHP scripts with the permissions of their owners
-Summary(pl):   Modu³ do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich w³a¶cicieli
+Summary(pl.UTF-8):     Moduł do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich właścicieli
 Name:          apache-mod_%{mod_name}
-Version:       0.5.2
-Release:       4
+Version:       0.6.1
+Release:       1
 License:       GPL
 Group:         Networking/Daemons
-Source0:       http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz     
-# Source0-md5: 337909e87027af124052baddddbd2994
+Source0:       http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz
+# Source0-md5: 7eb8ae29404392d9eb07c69d5242d716
 Source1:       %{name}.logrotate
 Source2:       %{name}.conf
+Source3:       %{name}-suphp.conf
 Patch0:                %{name}-apr.patch
+Patch1:                %{name}-compiler-flags.patch
+Patch2:                %{name}-apache_version.patch
 URL:           http://www.suphp.org/
-BuildRequires: %{apxs}
+BuildRequires: apache-apxs >= 2.0.52-2
 BuildRequires: apache-devel >= 2.0.52-2
 BuildRequires: autoconf
 BuildRequires: automake
-Requires(post,preun):  %{apxs}
-Requires:      apache >= 2.0.52-2
+BuildRequires: libstdc++-devel
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires:      apache(modules-api) = %apache_modules_api
 Requires:      php-cgi
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
-suPHP is a tool for executing PHP scripts with the permissions of their
-owners. It consists of an Apache module (mod_suphp) and a setuid root
-binary (suphp) that is called by the Apache module to change the uid of
-the process executing the PHP interpreter.
+suPHP is a tool for executing PHP scripts with the permissions of
+their owners. It consists of an Apache module (mod_suphp) and a setuid
+root binary (suphp) that is called by the Apache module to change the
+uid of the process executing the PHP interpreter.
 
-%description -l pl
-suPHP jest narzêdziem pozwalaj±cym na wykonywanie skryptów PHP z
-uprawnieniami ich w³a¶cicieli. Sk³ada siê z modu³u (mod_suphp) oraz
-programu (suphp) z ustawionym bitem suid, który uruchamiany jest przez
-modu³ w celu zmiany uid procesu uruchamiaj±cego interpreter PHP.
+%description -l pl.UTF-8
+suPHP jest narzędziem pozwalającym na wykonywanie skryptów w PHP z
+uprawnieniami ich właścicieli. Składa się z modułu (mod_suphp) oraz
+programu (suphp) z ustawionym bitem suid, który uruchamiany jest przez
+moduł w celu zmiany uid procesu uruchamiającego interpreter PHP.
 
 %prep
 %setup -q -n %{mod_name}-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
-chmod 755 configure
+%{__automake}
+export APACHE_VERSION=$(rpm -q --qf '%%{version}' apache-apxs)
 %configure \
        %{?with_checkpath: --enable-checkpath} \
        %{!?with_checkpath: --disable-checkpath} \
@@ -59,43 +65,45 @@ chmod 755 configure
        --with-min-gid=1000 \
        --with-apxs=%{apxs} \
        --disable-checkuid \
-       --disable-checkgid 
+       --disable-checkgid \
+       --with-setid-mode=owner \
+       --with-logfile=/var/log/httpd/suphp_log
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir}}
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_datadir}/suphp}
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
 
 install src/suphp $RPM_BUILD_ROOT%{_sbindir}
 install src/apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod-suphp.conf
+install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod_%{mod_name}.conf
+install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{mod_name}.conf
 
 install -d $RPM_BUILD_ROOT/etc/logrotate.d
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
 
+install doc/suphp.conf-example $RPM_BUILD_ROOT%{_datadir}/suphp
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
+%service -q httpd restart
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
-       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc README AUTHORS ChangeLog doc
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
 %attr(4755,root,root) %{_sbindir}/suphp
-%attr(755,root,root) %{_pkglibdir}/*
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
+%dir %{_datadir}/suphp
+%{_datadir}/suphp/*
This page took 0.039458 seconds and 4 git commands to generate.