]> git.pld-linux.org Git - packages/apache-mod_suphp.git/blame - apache-mod_suphp.spec
- rel 3
[packages/apache-mod_suphp.git] / apache-mod_suphp.spec
CommitLineData
9416cacc
AG
1#
2# Available build options:
4f71446b 3%bcond_with checkpath # enable check if php execution is within DOCUMENT_ROOT of the vhost
9416cacc 4#
f728b606
AG
5%define mod_name suphp
6%define apxs /usr/sbin/apxs
7Summary: Apache module: suPHP - execute PHP scripts with the permissions of their owners
dd7674a9 8Summary(pl.UTF-8): Moduł do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich właścicieli
f728b606 9Name: apache-mod_%{mod_name}
d221d949 10Version: 0.7.1
cc041e33 11Release: 3
f728b606 12License: GPL
0dca1078 13Group: Networking/Daemons/HTTP
3c364514 14Source0: http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz
d221d949 15# Source0-md5: c172dd4f15a75f4dcb08ea97d4202bb8
80f911b6 16Source1: %{name}.logrotate
17Source2: %{name}.conf
e5964759 18Source3: %{name}-suphp.conf
9bdf7b7c
AG
19Patch0: %{name}-compiler-flags.patch
20Patch1: %{name}-apache_version.patch
f728b606 21URL: http://www.suphp.org/
053bbfa6 22BuildRequires: %{apxs}
cdd38411 23BuildRequires: apache-devel >= 2.0.52-2
18fcd50c
JB
24BuildRequires: autoconf
25BuildRequires: automake
6577b666 26BuildRequires: libstdc++-devel
9bdf7b7c 27BuildRequires: libtool
61194e06 28BuildRequires: rpmbuild(macros) >= 1.268
4f71446b 29Requires: apache(modules-api) = %apache_modules_api
987c9698 30Requires: php-cgi
5751bdbd 31Conflicts: logrotate < 3.7-4
f728b606
AG
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
83d5fc38
ER
34%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
35%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
f728b606
AG
36
37%description
3c364514
AG
38suPHP is a tool for executing PHP scripts with the permissions of
39their owners. It consists of an Apache module (mod_suphp) and a setuid
40root binary (suphp) that is called by the Apache module to change the
41uid of the process executing the PHP interpreter.
f728b606 42
e45c9df2
JR
43%description -l pl.UTF-8
44suPHP jest narzędziem pozwalającym na wykonywanie skryptów w PHP z
45uprawnieniami ich właścicieli. Składa się z modułu (mod_suphp) oraz
46programu (suphp) z ustawionym bitem suid, który uruchamiany jest przez
47moduł w celu zmiany uid procesu uruchamiającego interpreter PHP.
f728b606
AG
48
49%prep
50%setup -q -n %{mod_name}-%{version}
fc2af1ea 51%patch0 -p1
72e21711 52%patch1 -p1
f728b606
AG
53
54%build
9bdf7b7c 55%{__libtoolize}
f728b606
AG
56%{__aclocal}
57%{__autoconf}
58%{__autoheader}
72e21711 59%{__automake}
83d5fc38 60APACHE_VERSION=$(rpm -q --qf '%{V}' apache-devel); export APACHE_VERSION
18fcd50c 61%configure \
83d5fc38 62 --%{?with_checkpath:en}%{!?with_checkpath:dis}able-checkpath \
18fcd50c 63 --with-apache-user=http \
48cd0203 64 --with-min-uid=500 \
9416cacc
AG
65 --with-min-gid=1000 \
66 --with-apxs=%{apxs} \
9bdf7b7c 67 --with-apr=%{_bindir}/apr-1-config \
e5964759
JR
68 --with-setid-mode=owner \
69 --with-logfile=/var/log/httpd/suphp_log
48cd0203 70
f728b606
AG
71%{__make}
72
f728b606
AG
73%install
74rm -rf $RPM_BUILD_ROOT
83d5fc38
ER
75install -d $RPM_BUILD_ROOT{%{_sbindir},%{apachelibdir},%{_datadir}/suphp}
76install -d $RPM_BUILD_ROOT%{apacheconfdir}
f728b606 77
e78edc9b 78install src/suphp $RPM_BUILD_ROOT%{_sbindir}
83d5fc38
ER
79install src/apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
80install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/70_mod_%{mod_name}.conf
e5964759 81install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{mod_name}.conf
f728b606 82
18fcd50c
JB
83install -d $RPM_BUILD_ROOT/etc/logrotate.d
84install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
9416cacc 85
630dd324
MG
86install doc/suphp.conf-example $RPM_BUILD_ROOT%{_datadir}/suphp
87
f728b606
AG
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post
61194e06 92%service -q httpd restart
f728b606 93
3057f748 94%postun
f728b606 95if [ "$1" = "0" ]; then
61194e06 96 %service -q httpd restart
f728b606
AG
97fi
98
99%files
100%defattr(644,root,root,755)
101%doc README AUTHORS ChangeLog doc
83d5fc38 102%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
e5964759 103%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{mod_name}.conf
83d5fc38 104%attr(755,root,root) %{apachelibdir}/*.so
f9a8a397 105%attr(4755,root,root) %{_sbindir}/suphp
3c364514 106%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
4f71446b 107%dir %{_datadir}/suphp
630dd324 108%{_datadir}/suphp/*
This page took 0.048362 seconds and 4 git commands to generate.