]> git.pld-linux.org Git - packages/apache-mod_suphp.git/blame - apache-mod_suphp.spec
- BR s@%{apxs}@apache-apxs@g
[packages/apache-mod_suphp.git] / apache-mod_suphp.spec
CommitLineData
9416cacc
AG
1#
2# Available build options:
4f71446b 3%bcond_with checkpath # enable check if php execution is within DOCUMENT_ROOT of the vhost
9416cacc 4#
f728b606
AG
5%define mod_name suphp
6%define apxs /usr/sbin/apxs
7Summary: Apache module: suPHP - execute PHP scripts with the permissions of their owners
dd7674a9 8Summary(pl.UTF-8): Moduł do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich właścicieli
f728b606 9Name: apache-mod_%{mod_name}
e2195df5 10Version: 0.6.1
e5964759 11Release: 1
f728b606
AG
12License: GPL
13Group: Networking/Daemons
3c364514 14Source0: http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz
e2195df5 15# Source0-md5: 7eb8ae29404392d9eb07c69d5242d716
80f911b6 16Source1: %{name}.logrotate
17Source2: %{name}.conf
e5964759 18Source3: %{name}-suphp.conf
fc2af1ea 19Patch0: %{name}-apr.patch
630dd324 20Patch1: %{name}-compiler-flags.patch
4f71446b 21Patch2: %{name}-apache_version.patch
f728b606 22URL: http://www.suphp.org/
a5f28e33 23BuildRequires: apache-apxs >= 2.0.52-2
cdd38411 24BuildRequires: apache-devel >= 2.0.52-2
18fcd50c
JB
25BuildRequires: autoconf
26BuildRequires: automake
6577b666 27BuildRequires: libstdc++-devel
61194e06 28BuildRequires: rpmbuild(macros) >= 1.268
4f71446b 29Requires: apache(modules-api) = %apache_modules_api
987c9698 30Requires: php-cgi
f728b606
AG
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
4f71446b
ER
33%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
34%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
f728b606
AG
35
36%description
3c364514
AG
37suPHP is a tool for executing PHP scripts with the permissions of
38their owners. It consists of an Apache module (mod_suphp) and a setuid
39root binary (suphp) that is called by the Apache module to change the
40uid of the process executing the PHP interpreter.
f728b606 41
e45c9df2
JR
42%description -l pl.UTF-8
43suPHP jest narzędziem pozwalającym na wykonywanie skryptów w PHP z
44uprawnieniami ich właścicieli. Składa się z modułu (mod_suphp) oraz
45programu (suphp) z ustawionym bitem suid, który uruchamiany jest przez
46moduł w celu zmiany uid procesu uruchamiającego interpreter PHP.
f728b606
AG
47
48%prep
49%setup -q -n %{mod_name}-%{version}
fc2af1ea 50%patch0 -p1
72e21711 51%patch1 -p1
4f71446b 52%patch2 -p1
f728b606
AG
53
54%build
55%{__aclocal}
56%{__autoconf}
57%{__autoheader}
72e21711 58%{__automake}
4f71446b 59export APACHE_VERSION=$(rpm -q --qf '%%{version}' apache-apxs)
18fcd50c 60%configure \
762229de
AM
61 %{?with_checkpath: --enable-checkpath} \
62 %{!?with_checkpath: --disable-checkpath} \
18fcd50c 63 --with-apache-user=http \
48cd0203 64 --with-min-uid=500 \
9416cacc
AG
65 --with-min-gid=1000 \
66 --with-apxs=%{apxs} \
762229de 67 --disable-checkuid \
e5964759
JR
68 --disable-checkgid \
69 --with-setid-mode=owner \
70 --with-logfile=/var/log/httpd/suphp_log
48cd0203 71
f728b606
AG
72%{__make}
73
f728b606
AG
74%install
75rm -rf $RPM_BUILD_ROOT
630dd324 76install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_datadir}/suphp}
80f911b6 77install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
f728b606 78
e78edc9b 79install src/suphp $RPM_BUILD_ROOT%{_sbindir}
39cfdd8f 80install src/apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
96582c5b 81install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod_%{mod_name}.conf
e5964759 82install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{mod_name}.conf
f728b606 83
18fcd50c
JB
84install -d $RPM_BUILD_ROOT/etc/logrotate.d
85install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
9416cacc 86
630dd324
MG
87install doc/suphp.conf-example $RPM_BUILD_ROOT%{_datadir}/suphp
88
f728b606
AG
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post
61194e06 93%service -q httpd restart
f728b606 94
3057f748 95%postun
f728b606 96if [ "$1" = "0" ]; then
61194e06 97 %service -q httpd restart
f728b606
AG
98fi
99
100%files
101%defattr(644,root,root,755)
102%doc README AUTHORS ChangeLog doc
96582c5b 103%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
e5964759 104%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{mod_name}.conf
96582c5b 105%attr(755,root,root) %{_pkglibdir}/*.so
f9a8a397 106%attr(4755,root,root) %{_sbindir}/suphp
3c364514 107%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
4f71446b 108%dir %{_datadir}/suphp
630dd324 109%{_datadir}/suphp/*
This page took 0.073951 seconds and 4 git commands to generate.