]> git.pld-linux.org Git - packages/apache-mod_security.git/blob - apache-mod_security.spec
- initial
[packages/apache-mod_security.git] / apache-mod_security.spec
1 %define         mod_name        security
2 %define         apxs            %{_sbindir}/apxs
3 Summary:        Apache module: securing web applications
4 Summary(pl):    Modu³ do apache: ochrona aplikacji webowych
5 Name:           apache-mod_%{mod_name}
6 Version:        1.8.6
7 Release:        0.1
8 License:        GPL v2
9 Group:          Networking/Daemons
10 Source0:        http://www.modsecurity.org/download/mod_security-%{version}.tar.gz
11 # Source0-md5:  f6bf4724dd0db3d37586b64bc0ee160d
12 URL:            http://sourceforge.net/projects/mod-acct/
13 BuildRequires:  apache-devel
14 Requires(post,preun):   %{apxs}
15 Requires:       apache
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
19 %define         _sysconfdir     /etc/httpd
20
21 %description
22 ModSecurity is an open source intrusion detection and
23 prevention engine for web applications. It operates embedded
24 into the web server, acting as a powerful umbrella - shielding
25 web applications from attacks.
26
27 %description -l pl
28 ModSecurity jest otwartym silnikiem wykrywania i zapobiegania 
29 intruzom dla aplikacji webowych. Oferuje wbudwany w serwer www,
30 dzia³aj±c jak potê¿ny parasol chroni±cy aplikacje webowe przed
31 atakami.
32
33 %prep
34 %setup -q -n mod_%{mod_name}-%{version}
35
36 %build
37 cd apache2
38 %{apxs} -c mod_%{mod_name}.c
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{_pkglibdir}
43
44 install apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51 if [ -f /var/lock/subsys/httpd ]; then
52         /etc/rc.d/init.d/httpd restart 1>&2
53 fi
54
55 %preun
56 if [ "$1" = "0" ]; then
57         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
58         if [ -f /var/lock/subsys/httpd ]; then
59                 /etc/rc.d/init.d/httpd restart 1>&2
60         fi
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README CHANGES modsecurity-manual.pdf httpd.conf*
66 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.028018 seconds and 4 git commands to generate.