]> git.pld-linux.org Git - packages/apache-mod_security.git/blob - apache-mod_security.spec
424182162eb7e1bff5042150dd040e44f0a9199d
[packages/apache-mod_security.git] / apache-mod_security.spec
1 %define         mod_name        security
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: securing web applications
4 Summary(pl):    Modu³ do apache: ochrona aplikacji WWW
5 Name:           apache-mod_%{mod_name}
6 %define _pre    %{nil}
7 Version:        1.9.1
8 Release:        1
9 License:        GPL v2
10 Group:          Networking/Daemons
11 Source0:        http://www.modsecurity.org/download/modsecurity-apache-%{version}%{_pre}.tar.gz
12 # Source0-md5:  d648ba26b1dba708a06344072bea984c
13 URL:            http://www.modsecurity.org/
14 BuildRequires:  apache-devel
15 Requires(post,preun):   %{apxs}
16 Requires:       apache
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
20 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
21
22 %description
23 ModSecurity is an open source intrusion detection and prevention
24 engine for web applications. It operates embedded into the web server,
25 acting as a powerful umbrella - shielding web applications from
26 attacks.
27
28 %description -l pl
29 ModSecurity jest otwartym silnikiem wykrywania i zapobiegania intruzom
30 dla aplikacji WWW. Operuje w ramach serwera WWW, dzia³aj±c jak
31 potê¿ny parasol chroni±cy aplikacje WWW przed atakami.
32
33 %prep
34 %setup -q -n modsecurity-apache-%{version}%{_pre}
35
36 %build
37 cd apache2
38 %{apxs} -c mod_%{mod_name}.c
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{_pkglibdir}
43
44 install apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51 if [ -f /var/lock/subsys/httpd ]; then
52         /etc/rc.d/init.d/httpd restart 1>&2
53 fi
54
55 %preun
56 if [ "$1" = "0" ]; then
57         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
58         if [ -f /var/lock/subsys/httpd ]; then
59                 /etc/rc.d/init.d/httpd restart 1>&2
60         fi
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README CHANGES httpd.conf*
66 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.03964 seconds and 2 git commands to generate.