]> git.pld-linux.org Git - packages/apache-mod_qos.git/blob - apache-mod_qos.spec
- initial
[packages/apache-mod_qos.git] / apache-mod_qos.spec
1 %define         mod_name        qos
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: Quality Of Service
4 Name:           apache-mod_%{mod_name}
5 Version:        11.1
6 Release:        1
7 License:        Apache
8 Group:          Networking/Daemons/HTTP
9 Source0:        https://downloads.sourceforge.net/project/mod-qos/mod_qos-%{version}.tar.gz
10 # Source0-md5:  286d2d2b2f5abae9ccc48fa58f17dda1
11 Source1:        %{name}.conf
12 URL:            http://opensource.adnovum.ch/mod_qos/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel >= 2.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 Requires:       apache(modules-api) = %apache_modules_api
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
20 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
21
22 %description
23 mod_qos is a quality of service module for the Apache Web Server. It
24 implements control mechanisms that can provide different priority to
25 different requests and controls server access based on available
26 resources.
27
28 %prep
29 %setup -q -n mod_%{mod_name}-%{version}
30
31 %build
32 cd tools
33 %{__aclocal}
34 %{__autoconf}
35 %{__automake}
36 %configure \
37         --with-apxs=%{apxs}
38 %{__make}
39 cd ..
40
41 %{apxs} -c -o mod_qos.la apache2/mod_qos.c
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
46
47 %{__make} -C tools install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 cp -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
51 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/97_mod_%{mod_name}.conf
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %service -q httpd restart
58
59 %postun
60 if [ "$1" = "0" ]; then
61         %service -q httpd restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc doc/*
67 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*mod_*.conf
68 %attr(755,root,root) %{apachelibdir}/*.so
69 %attr(755,root,root) %{_bindir}/qs*
This page took 0.063963 seconds and 3 git commands to generate.