]> git.pld-linux.org Git - packages/apache-mod_perl.git/blobdiff - apache-mod_perl.spec
- added systemd support
[packages/apache-mod_perl.git] / apache-mod_perl.spec
index 063ea8945ff892c0e9645727056e6b7570c88199..c31e373cacff2540642fd285ea765ee9656d1f06 100644 (file)
@@ -11,7 +11,7 @@
 
 %define                ver     2.0.7
 %define                snap    svn1448242
-%define                rel     4
+%define                rel     9
 Summary:       A Perl interpreter for the Apache Web server
 Summary(cs.UTF-8):     Vestavěný interpret Perlu pro WWW server Apache
 Summary(da.UTF-8):     En indbygget Perl-fortolker for webtjeneren Apache
@@ -44,6 +44,7 @@ Source0:      mod_perl-%{version}-%{snap}.tar.gz
 # Source0-md5: 8b62bbfe8b499bc87b6d3d28eb765a24
 Source1:       %{name}.conf
 Patch0:                %{name}-Makefile_PL.patch
+Patch1:                perl-5.18.patch
 URL:           http://perl.apache.org/
 BuildRequires: apache-devel >= 2.0.55-1
 BuildRequires: apr-util-devel >= 1:1.0.0
@@ -51,10 +52,9 @@ BuildRequires:       expat-devel
 BuildRequires: gdbm-devel
 BuildRequires: openldap-devel >= 2.4.6
 %{?with_autodeps:BuildRequires:        perl-Data-Flow}
-BuildRequires: perl-devel >= 1:5.8.2
-BuildConflicts:        perl-Module-CoreList
+BuildRequires: perl-devel >= 1:5.18.0
 BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: rpmbuild(macros) >= 1.671
 %if %{with tests}
 BuildRequires: apache-mod_auth_basic
 BuildRequires: apache-mod_authz_host
@@ -67,9 +67,13 @@ BuildRequires:       perl-CGI >= 3.22
 %endif
 # older apache-mod_perl could make bad autodeps to perl-mod_perl
 BuildConflicts:        apache-mod_perl < 1:2.0.2-9
+Requires(post,preun,postun):   systemd-units >= 38
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      perl-mod_%{mod_name} = %{epoch}:%{version}-%{release}
+Requires:      rc-scripts
+Requires:      systemd-units >= 38
 Provides:      apache(mod_perl)
+Obsoletes:     perl-Apache-Reload
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # TODO: separate -devel with ExtUtils::Embed and friends?
@@ -238,7 +242,7 @@ Perlowe API dla mod_perla.
 %package -n perl-Apache-Test
 Summary:       Apache::Test - Test.pm wrapper with helpers for testing Apache
 Summary(pl.UTF-8):     Apache::Test - wrapper na Test.pm z funkcjami do testowania Apache
-Version:       1.36
+Version:       1.37
 Group:         Development/Languages/Perl
 Requires:      perl-mod_%{mod_name} = %{epoch}:%{ver}-%{release}
 Requires:      perl-dirs >= 2.0-5
@@ -254,6 +258,7 @@ pomocnicze do testowania serwera Apache.
 %prep
 %setup -q -n mod_%{mod_name}-%{ver}-%{snap}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__perl} Makefile.PL \
@@ -263,8 +268,8 @@ pomocnicze do testowania serwera Apache.
        INSTALLDIRS=vendor
 
 %{__make} \
-       OPTIMIZE="%{rpmcflags}" \
-       MODPERL_OPTIMIZE="%{rpmcflags}" \
+       OPTIMIZE="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
+       MODPERL_OPTIMIZE="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
        CC="%{__cc}" \
        MP_APXS=%{apxs}
 
@@ -299,10 +304,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %post
 %service -q httpd restart
+%systemd_service_restart httpd.service
 
 %postun
 if [ "$1" = "0" ]; then
        %service -q httpd restart
+       %systemd_service_restart httpd.service
 fi
 
 %files
This page took 0.10044 seconds and 4 git commands to generate.