]> git.pld-linux.org Git - packages/apache-mod_perl.git/blobdiff - apache-mod_perl.spec
- rel 2 (rebuild with new apache)
[packages/apache-mod_perl.git] / apache-mod_perl.spec
index b41dd41a77a6ad185921252d1b2317dbd40a1a5c..a149027f1314abab429beb218d0d9fa76b315d5b 100644 (file)
@@ -2,7 +2,6 @@
 # - separate perl-things from apache libs and configs (needed for some buildings)
 %include       /usr/lib/rpm/macros.perl
 %define        apxs    /usr/sbin/apxs
-# %define      snap    20031007
 Summary:       A Perl interpreter for the Apache Web server
 Summary(cs):   Vestavìný interpret Perlu pro WWW server Apache
 Summary(da):   En indbygget Perl-fortolker for webtjeneren Apache
@@ -23,48 +22,37 @@ Summary(sv):        En inbyggd Perl-interpretator f
 Summary(uk):   íÏÄÕÌØ ×ÂÕÄÏ×Õ×ÁÎÎÑ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÁ Perl × ÓÅÒ×ÅÒ Apache
 Summary(zh_CN):        ÓÃÓÚ Apache web ·þÎñ³ÌÐòµÄ Perl ½âÊͳÌÐò¡£
 Name:          apache-mod_perl
-Version:       1.99_17
+Version:       2.0.2
 Release:       2
 Epoch:         1
 License:       Apache
 Group:         Networking/Daemons
-#Source0:      modperl-%{version}_%{snap}.tar.bz2
 Source0:       http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
-# Source0-md5: ffb9d5c825b93d91e6c3a8885f7d5296
+# Source0-md5: ad0a509fd34e3b8452887d80a1d45dea
 Source1:       %{name}.conf
 Patch0:                %{name}-Makefile_PL.patch
 URL:           http://perl.apache.org/
-BuildRequires: apache-devel >= 2.0.0
+BuildRequires: apache-devel >= 2.0.55-1
 BuildRequires: apr-util-devel >= 1:1.0.0
 BuildRequires: expat-devel
 BuildRequires: gdbm-devel
 BuildRequires: openldap-devel
-# These modules aren't needed?
-#BuildRequires:        perl-B-Graph
-#BuildRequires:        perl-BSD-Resource
-#BuildRequires:        perl-Devel-Symdump
-#BuildRequires:        perl-HTML-Parser
-#BuildRequires:        perl-MIME-Base64
-#BuildRequires:        perl-URI
-#BuildRequires:        perl-devel >= 5.6.1
-#BuildRequires:        perl-libwww
+BuildRequires: perl-devel >= 1:5.8.2
 BuildRequires: rpm-perlprov >= 3.0.3-16
-%requires_eq   apache
-%requires_eq   perl-base
-Requires(post,preun):  %{apxs}
+%requires_eq_to        apache apache-devel
+Requires:      apache(modules-api) = %apache_modules_api
+Requires:      perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
 # What's this for?
 Provides:      perl(mod_perl_hooks)
 Provides:      mod_perl
 Provides:      perl-Apache-Test
-# bugs in rpm perl dependency finder?
-Provides:      perl(Apache::FunctionTable)
-Provides:      perl(Apache::StructureTable)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     mod_perl
 Obsoletes:     mod_perl-common
+Conflicts:     perl-modules < 1:5.8.6-6
 
 # TODO: separate -devel with ExtUtils::Embed and friends?
-%define                _noautoreq      'perl(Apache::.*)' 'perl(mod_perl)' 'perl(ModPerl::.*)' 'perl(ExtUtils::Embed)'
+%define                _noautoreq      'perl(Apache::.*)' 'perl(mod_perl)' 'perl(ModPerl::.*)' 'perl(ExtUtils::Embed)' 'perl(Module::Build)'
 %define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
@@ -200,14 +188,14 @@ Apache web 
 
 %prep
 %setup -q -n mod_perl-%{version}
-%patch0 -b .orig -p1
+%patch0 -p1
 
 %build
 %{__perl} Makefile.PL \
        MP_APXS=%{apxs} \
        MP_APR_CONFIG=%{_bindir}/apr-1-config \
-       INSTALLDIRS=vendor \
-       MP_CCOPTS="-I/usr/include/apache `apu-1-config --includes`" 
+       MP_APU_CONFIG=%{_bindir}/apu-1-config \
+       INSTALLDIRS=vendor
 
 %{__make} \
        OPTIMIZE="%{rpmcflags}" \
@@ -222,6 +210,13 @@ install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 find $RPM_BUILD_ROOT -name \*.orig -exec rm -f '{}' \;
+
+install xs/tables/current/Apache2/* $RPM_BUILD_ROOT%{perl_vendorarch}/Apache2
+install xs/tables/current/APR/* $RPM_BUILD_ROOT%{perl_vendorarch}/APR
+install xs/tables/current/ModPerl/* $RPM_BUILD_ROOT%{perl_vendorarch}/ModPerl
+
+rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle
+rm -f $RPM_BUILD_ROOT%{_mandir}/man?/Bundle*
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/75_mod_perl.conf
 
 %clean
@@ -241,30 +236,30 @@ if [ "$1" = "0" ]; then
        fi
 fi
 
-
 %files
 %defattr(644,root,root,755)
 %doc Changes INSTALL README STATUS
 %attr(755,root,root) %{_pkglibdir}/*.so
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*.conf
 
 %{perl_vendorarch}/*.pm
 %{perl_vendorarch}/APR
 %{perl_vendorarch}/Apache
+%{perl_vendorarch}/Apache2
 %{perl_vendorarch}/ModPerl
 
 %dir %{perl_vendorarch}/auto/*
 %{perl_vendorarch}/auto/*/*.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/*/*.so
 %dir %{perl_vendorarch}/auto/APR/[B-U]*
-%dir %{perl_vendorarch}/auto/Apache/[A-U]*
+%dir %{perl_vendorarch}/auto/Apache2/[A-U]*
 %dir %{perl_vendorarch}/auto/ModPerl/*
 %{perl_vendorarch}/auto/*/*/*.ix
 %{perl_vendorarch}/auto/*/*/*.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/*/*/*.so
 
-%{perl_vendorarch}/auto/Apache/typemap
+%{perl_vendorarch}/auto/Apache2/typemap
 # to -devel? directory ownership problem...
 %{_includedir}/apache/*.h
 
-%{_mandir}/man?/[!B]*
+%{_mandir}/man?/*
This page took 0.036202 seconds and 4 git commands to generate.