]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/commitdiff
use gyp defines to correct include paths
authorElan Ruusamäe <glen@delfi.ee>
Wed, 10 Oct 2012 22:19:20 +0000 (01:19 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 1 Mar 2013 23:48:23 +0000 (01:48 +0200)
apache-mod_pagespeed.spec
system-libs.patch

index 9f92e3f41a76efdbfb8fa48154c36a12f247ca72..d5fb25b65a3af37fa70c2e25c1e539986f3c8ca9 100644 (file)
@@ -7,7 +7,6 @@
 # - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
 # TODO
 # - add unit tests running
-# - use only source for modpagespeed if system headers are used (remove copies from tarball)
 # - possible sysdeps (uses release tags)
 #  "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
 #  "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
@@ -95,6 +94,9 @@ CXX="%{__cxx}" \
        -Duse_system_libpng=1 \
        -Duse_system_opencv=1 \
        -Duse_system_zlib=1 \
+       -Dsystem_include_path_apr=%{_includedir}/apr \
+       -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
+       -Dsystem_include_path_httpd=%{_includedir}/apache \
        %{nil}
 
 cd ..
index d394a778ac2c2b2f6c7c6ee3b18ac67715607010..a03dbb5dea59ab0638832debb25e71c3c79934fb 100644 (file)
@@ -1,36 +1,3 @@
---- modpagespeed/src/third_party/apr/apr.gyp~  2012-06-24 15:31:59.000000000 +0300
-+++ modpagespeed/src/third_party/apr/apr.gyp   2012-07-07 14:44:06.094870546 +0300
-@@ -19,7 +19,7 @@
-     'apr_src_root': '<(apr_root)/src',
-     'apr_gen_os_root': '<(apr_root)/gen/arch/<(OS)',
-     'apr_gen_arch_root': '<(apr_gen_os_root)/<(target_arch)',
--    'system_include_path_apr%': '/usr/include/apr-1.0',
-+    'system_include_path_apr%': '/usr/include/apr',
-     'conditions': [
-       ['OS!="win"', {
-         'apr_os_include': '<(apr_src_root)/include/arch/unix',
---- modpagespeed/src/third_party/aprutil/aprutil.gyp~  2012-06-24 15:31:59.000000000 +0300
-+++ modpagespeed/src/third_party/aprutil/aprutil.gyp   2012-07-07 14:48:10.299435236 +0300
-@@ -22,7 +22,7 @@
-     'aprutil_src_root': '<(aprutil_root)/src',
-     'aprutil_gen_os_root': '<(aprutil_root)/gen/arch/<(OS)',
-     'aprutil_gen_arch_root': '<(aprutil_gen_os_root)/<(target_arch)',
--    'system_include_path_aprutil%': '/usr/include/apr-1.0',
-+    'system_include_path_aprutil%': '/usr/include/apr-util',
-   },
-   'conditions': [
-     ['use_system_apache_dev==0', {
---- modpagespeed/src/third_party/httpd/httpd.gyp~      2012-06-24 15:31:59.000000000 +0300
-+++ modpagespeed/src/third_party/httpd/httpd.gyp       2012-07-07 15:15:13.598943424 +0300
-@@ -18,7 +18,7 @@
-     'apache_src_root': '<(apache_root)/src',
-     'apache_gen_os_root': '<(apache_root)/gen/arch/<(OS)',
-     'apache_gen_arch_root': '<(apache_gen_os_root)/<(target_arch)',
--    'system_include_path_httpd%': '/usr/include/apache2',
-+    'system_include_path_httpd%': '/usr/include/apache',
-     'conditions': [
-       ['OS!="win"', {
-         'apache_os_include': '<(apache_src_root)/os/unix',
 --- modpagespeed/src/build/install.gyp~        2012-06-24 15:31:45.000000000 +0300
 +++ modpagespeed/src/build/install.gyp 2012-07-07 15:41:33.416812382 +0300
 @@ -43,7 +43,6 @@
This page took 0.094563 seconds and 4 git commands to generate.