]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/commitdiff
move clean source to separate script
authorElan Ruusamäe <glen@delfi.ee>
Tue, 16 Dec 2014 21:01:19 +0000 (23:01 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 16 Dec 2014 21:01:19 +0000 (23:01 +0200)
clean-source.sh [new file with mode: 0755]
get-source.sh

diff --git a/clean-source.sh b/clean-source.sh
new file mode 100755 (executable)
index 0000000..4a111d4
--- /dev/null
@@ -0,0 +1,29 @@
+#!/bin/sh
+set -xe
+
+# There are directories we want to strip, but that are unnecessarily required by the build-system
+# So we drop everything but the gyp/gypi files
+almost_strip_dirs() {
+       for dir in "$@"; do
+               find $dir -depth -mindepth 1 '!' '(' -name '*.gyp' -o -name '*.gypi' ')' -print -delete || :
+       done
+}
+
+export LC_ALL=C
+
+# clean sources, but preserve .gyp, .gypi
+almost_strip_dirs \
+       third_party/apr/ \
+       third_party/httpd/ \
+       third_party/httpd24/ \
+       third_party/instaweb/ \
+       third_party/openssl/ \
+
+# some more unneeded files for build
+rm -r third_party/chromium/src/net
+rm -r third_party/chromium/src/chrome
+rm -r net/instaweb/rewriter/testdata
+
+# build/linux and third_party/chromium/src/build/linux are same dirs, the latter is not usedc
+#rm -r third_party/chromium/src/build/linux
+#third_party/chromium/src/build/linux
index b5676abacdd6594931986347b79a99990ecedb65..c3e683fa7b9f5107e2faef107243b237c59fa5e3 100755 (executable)
@@ -13,18 +13,10 @@ version=
 spec=apache-mod_pagespeed.spec
 force=0
 
-# There are directories we want to strip, but that are unnecessarily required by the build-system
-# So we drop everything but the gyp/gypi files
-almost_strip_dirs() {
-       for dir in "$@"; do
-               find $dir -depth -mindepth 1 '!' '(' -name '*.gyp' -o -name '*.gypi' ')' -print -delete || :
-       done
-}
-
 # abort on errors
 set -e
 # work in package dir
-dir=$(dirname "$0")
+dir=$(readlink -f $(dirname "$0"))
 cd "$dir"
 
 if [[ "$1" = *force ]]; then
@@ -97,22 +89,7 @@ $gclient sync --nohooks -v
 
 cd src
 
-# clean sources, but preserve .gyp, .gypi
-almost_strip_dirs \
-       third_party/apr/ \
-       third_party/httpd/ \
-       third_party/httpd24/ \
-       third_party/instaweb/ \
-       third_party/openssl/ \
-
-# some more unneeded files for build
-rm -r third_party/chromium/src/net
-rm -r third_party/chromium/src/chrome
-rm -r net/instaweb/rewriter/testdata
-
-# build/linux and third_party/chromium/src/build/linux are same dirs, the latter is not usedc
-#rm -r third_party/chromium/src/build/linux
-#third_party/chromium/src/build/linux
+sh -x $dir/clean-source.sh
 
 # Populate the LASTCHANGE file template as we will not include VCS info in tarball
 ./build/lastchange.sh . -o LASTCHANGE.in
This page took 0.055647 seconds and 4 git commands to generate.