]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/commitdiff
- up to 0.10.22.7; use .xz source auto/th/apache-mod_pagespeed-0.10.22.7-1
authorElan Ruusamäe <glen@delfi.ee>
Wed, 10 Oct 2012 20:29:27 +0000 (23:29 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 10 Oct 2012 20:29:27 +0000 (23:29 +0300)
apache-mod_pagespeed.spec
gclient.conf
get-source.sh [changed mode: 0644->0755]

index 02df6683d88f2bc5fd0fd302a7f1e57d309fe53f..f3d010d74824e10b94e2c9bf573214fdee925efc 100644 (file)
 %define        apxs            %{_sbindir}/apxs
 Summary:       Apache module for rewriting web pages to reduce latency and bandwidth
 Name:          apache-mod_%{mod_name}
-Version:       0.10.22.4
+Version:       0.10.22.7
 Release:       1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
-Source0:       modpagespeed-%{version}.tar.bz2
-# Source0-md5: 447f11184ab8b82f59b07a3e3b99425a
+Source0:       modpagespeed-%{version}.tar.xz
+# Source0-md5: 1c67625812d18899ce6a47da069c6043
 Source1:       get-source.sh
 Patch0:                system-libs.patch
 Patch1:                gcc-headers.patch
@@ -42,13 +42,18 @@ BuildRequires:      gperf
 BuildRequires: libjpeg-devel
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:4.1
-BuildRequires: opencv-devel
+BuildRequires: opencv-devel >= 2.3.1
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel >= 1:2.6
-BuildRequires: python-gyp
+# This version of gyp is new enough that it knows to use make for Linux 3.x
+# and FreeBSD, but old enough that 'type': 'settings' works and
+# LINKER_SUPPORTS_ICF hasn't been removed yet.
+BuildRequires: python-gyp >= 1-1175
 BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: tar >= 1:1.22
 BuildRequires: util-linux
+BuildRequires: xz
 BuildRequires: zlib-devel
 # gcc4 might be installed, but not current __cc
 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
index 7dd8e260ef40497493b360c0bfe0a07a066706f9..e6de3a5bf71776fefc566276a15ba951332c39ab 100644 (file)
@@ -1,22 +1,29 @@
 solutions = [
   { "name"        : "src",
-    "url"         : "http://modpagespeed.googlecode.com/svn/tags/0.10.22.4/src",
+    "url"         : "http://modpagespeed.googlecode.com/svn/tags/0.10.22.7/src",
     "deps_file"   : "DEPS",
     "managed"     : True,
+
+       # deps that can be overriden, are top rooted for names in 'deps' in src/DEPS
     "custom_deps" : {
+               # apr >= 1.4.2
                "src/third_party/apr/src": None,
+
+               # apr-util >= 1.3.9
                "src/third_party/aprutil/src": None,
 
+               # apache >= 2.2.15
                "src/third_party/httpd/src/include": None,
                "src/third_party/httpd/src/os": None,
+
+               # apache >= 2.4.1
                "src/third_party/httpd24/src/include": None,
                "src/third_party/httpd24/src/os": None,
 
-               "src/third_party/opencv/src/opencv/include": None,
-               "src/third_party/opencv/src/opencv/modules/core": None,
-               "src/third_party/opencv/src/opencv/modules/imgproc": None,
-               "src/third_party/opencv/src/opencv/modules/highgui": None,
+               # need opencv >= 2.3.1
+               "src/third_party/opencv/src/opencv/": None,
 
+               # need gyp <= @1175
                "src/tools/gyp": None,
 
                # these contain needed .gyp, need to checkout
old mode 100644 (file)
new mode 100755 (executable)
index 68c1b61..ae32ec8
@@ -2,6 +2,9 @@
 # Usage:
 # ./get-source.sh
 # Author: Elan Ruusamäe <glen@pld-linux.org>
+#
+# To see release notes, see this page:
+# https://developers.google.com/speed/docs/mod_pagespeed/release_notes
 
 pkg=modpagespeed
 baseurl=http://modpagespeed.googlecode.com/svn
@@ -34,11 +37,11 @@ fi
 if [ "$version" = "trunk" ]; then
        echo "Using trunk"
        svnurl=$baseurl/trunk/src
-       tarball=$pkg-$(date +%Y%m%d).tar.bz2
+       tarball=$pkg-$(date +%Y%m%d).tar.xz
 else
        echo "Version: $version"
        svnurl=$baseurl/tags/$version/src
-       tarball=$pkg-$version.tar.bz2
+       tarball=$pkg-$version.tar.xz
 fi
 
 if [ -f $tarball -a $force != 1 ]; then
@@ -54,6 +57,8 @@ fi
 
 # http://www.chromium.org/developers/how-tos/install-depot-tools
 test -d depot_tools || {
+       # could also checkout:
+       # svn co http://src.chromium.org/svn/trunk/tools/depot_tools
        wget -c https://src.chromium.org/svn/trunk/tools/depot_tools.zip
        unzip -qq depot_tools.zip
 #      cd depot_tools
@@ -83,6 +88,6 @@ sed -i -re '/"url"/ s,"http[^"]+","'$svnurl'",' .gclient
 (cd src/build && svnversion > LASTCHANGE.in)
 cd ..
 
-tar -cjf $tarball --exclude-vcs $pkg
+tar -cJf $tarball --exclude-vcs $pkg
 ../md5 $spec
 ../dropin $tarball &
This page took 0.09636 seconds and 4 git commands to generate.