]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/commitdiff
- cleanup unused (bogus) deps, add missing BR detected by cleanbuild
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 7 Jul 2012 19:04:49 +0000 (19:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- default config loads mod_headers, depend on the package
- cleanup outdated todo
- fix install without hacking around ap24.so
- package examples

Changed files:
    apache-mod_pagespeed.spec -> 1.14

apache-mod_pagespeed.spec

index 1a068dc0739c52777fc30d93b9fe9fb5422e6a92..2b9792b9900312e5a2748cf6bae7c44bca2d16fd 100644 (file)
@@ -7,23 +7,9 @@
 # - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
 # TODO
 # - add unit tests running
-# - c++ errors on 64bit/32bit gcc 4.5.1-4:
-#   /usr/include/c++/4.5.1/bits/stl_map.h:87:5:   instantiated from here
-#   /usr/include/c++/4.5.1/bits/stl_pair.h:77:11: error: ‘std::pair<_T1, _T2>::second’ has incomplete type
-#   ./net/instaweb/util/public/cache_interface.h:28:7: error: forward declaration of ‘struct net_instaweb::SharedString’
-#   make[1]: *** [out/Release/obj.target/mod_pagespeed_test/net/instaweb/util/cache_fetcher_test.o] Error 1
-#   http://pastebin.com/Eu88BPSQ
-# - sizeof(apr_int32_t) == sizeof(apr_int64_t) on 32bit (!?!):
-#   third_party/apache/apr/src/strings/apr_snprintf.c: In function 'conv_os_thread_t':
-#   third_party/apache/apr/src/strings/apr_snprintf.c:500:5: error: duplicate case value
-#   third_party/apache/apr/src/strings/apr_snprintf.c:498:5: error: previously used here
-#   third_party/apache/apr/src/strings/apr_snprintf.c: In function 'conv_os_thread_t_hex':
-#   third_party/apache/apr/src/strings/apr_snprintf.c:671:5: error: duplicate case value
-#   third_party/apache/apr/src/strings/apr_snprintf.c:669:5: error: previously used here
 # - use only source for modpagespeed if system headers are used (remove copies from tarball)
 # - possible sysdeps (uses release tags)
 #  "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
-#  "apache_httpd_src": "http://svn.apache.org/repos/asf/httpd/httpd/tags/2.2.15",
 #  "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
 #  "google_sparsehash_root": "http://google-sparsehash.googlecode.com/svn/tags/sparsehash-1.8.1/src",
 #  protobuf_lite
@@ -40,7 +26,7 @@
 Summary:       Apache module for rewriting web pages to reduce latency and bandwidth
 Name:          apache-mod_%{mod_name}
 Version:       0.10.22.4
-Release:       0.7
+Release:       0.9
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       modpagespeed-%{version}.tar.bz2
@@ -55,8 +41,8 @@ BuildRequires:        dbus-glib-devel
 BuildRequires: fontconfig-devel
 BuildRequires: freetype-devel
 BuildRequires: glib2-devel
+BuildRequires: gperf
 BuildRequires: gtk+2-devel
-BuildRequires: ibus-devel >= 1.3.99.20110425
 BuildRequires: libgcrypt-devel
 BuildRequires: libgnome-keyring-devel
 BuildRequires: libjpeg-devel
@@ -65,6 +51,7 @@ BuildRequires:        libselinux-devel
 BuildRequires: libstdc++-devel >= 5:4.1
 BuildRequires: opencv-devel
 BuildRequires: openssl-devel
+BuildRequires: pkgconfig
 BuildRequires: python-devel >= 1:2.6
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: xorg-lib-libX11-devel
@@ -77,6 +64,7 @@ BuildRequires:        __cc >= 4.0
 %endif
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apache-mod_authz_host
+Requires:      apache-mod_headers
 Suggests:      apache-mod_deflate
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -113,7 +101,6 @@ CXX="%{__cxx}" \
        -Duse_system_libpng=1 \
        -Duse_system_opencv=1 \
        -Duse_system_zlib=1 \
-       -Duse_ibus=1 \
        %{nil}
 
 cd ..
@@ -135,29 +122,28 @@ default:
 EOF
 %{__make}
 
-# install.gyp needs fixing, not to install ap24.so, for now duplicate
-ln -f src/out/Release/libmod_pagespeed{,_ap24}.so
-
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -j1 -C src/install staging \
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{cachedir}/{cache,files}}
+%{__make} -j1 -C src/install staging_except_module \
        HOSTNAME=localhost \
        APACHE_ROOT=%{_pkgrootdir} \
-       APACHE_MODULES=%{_pkglibdir} \
+       APACHE_MODULES=modules \
        APACHE_DOC_ROOT=%{htdocsdir} \
        MOD_PAGESPEED_FILE_ROOT=%{cachedir} \
        STAGING_DIR=staging
 
+install -p src/out/Release/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
 cd src/install/staging
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
-install -p mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
-install -d $RPM_BUILD_ROOT%{cachedir}/{cache,files}
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
 LoadModule %{mod_name}_module  modules/mod_%{mod_name}.so
 
 $(cat pagespeed.conf)
 EOF
 
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -a mod_pagespeed_example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -173,6 +159,7 @@ fi
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
+%{_examplesdir}/%{name}-%{version}
 
 %dir %attr(710,root,http) %{cachedir}
 %dir %attr(770,root,http) %{cachedir}/cache
This page took 0.03441 seconds and 4 git commands to generate.