]> git.pld-linux.org Git - packages/apache-mod_mpm_itk.git/blame - apache-mod_mpm_itk.spec
Rel 3; fix session dir for php 8
[packages/apache-mod_mpm_itk.git] / apache-mod_mpm_itk.spec
CommitLineData
c9c87750
AM
1%define mod_name mpm_itk
2%define apxs /usr/sbin/apxs
3%define ver 2.4.7
72e00c45 4%define subver 04
c9c87750
AM
5Summary: mod_mpm_itk - allows you to run each of your vhost under a separate uid and gid
6Name: apache-mod_mpm_itk
7Version: %{ver}.%{subver}
d1c5d196 8Release: 3
c9c87750
AM
9License: Apache v2.0
10Group: Networking/Daemons/HTTP
11Source0: http://mpm-itk.sesse.net/mpm-itk-%{ver}-%{subver}.tar.gz
72e00c45 12# Source0-md5: a25d8db440858b593f1d6a4938fa3d02
10eb5784 13Source1: %{name}.conf
82dde414 14Source2: %{name}-php.conf
80f31863 15Source3: %{name}.tmpfiles
c9c87750
AM
16URL: http://mpm-itk.sesse.net/
17BuildRequires: %{apxs}
18BuildRequires: apache-devel >= 2.4.7
19BuildRequires: apr-devel >= 1:1.0
20BuildRequires: apr-util-devel >= 1:1.0
21BuildRequires: libcap-devel
22Requires: apache(modules-api) = %{apache_modules_api}
23Requires: apache-base >= 2.4.7
456f9439 24Requires: php-dirs >= 1.5-2
c9c87750
AM
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
28%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
29
30%description
31apache2-mpm-itk (just mpm-itk for short) is an MPM (Multi-Processing
32Module) for the Apache web server. mpm-itk allows you to run each of
ae0cdc1e 33your vhost under a separate uid and gid - in short, the scripts and
c9c87750
AM
34configuration files for one vhost no longer have to be readable for
35all the other vhosts.
36
37mpm-itk is based on the traditional prefork MPM, which means it's
38non-threaded; in short, this means you can run non-thread-aware code
39(like many PHP extensions) without problems. On the other hand, you
40lose out to any performance benefit you'd get with threads, of course;
41you'd have to decide for yourself if that's worth it or not. You will
42also take an additional performance hit over prefork, since there's an
43extra fork per request.
44
45%prep
46%setup -q -n mpm-itk-%{ver}-%{subver}
47
48%build
49%configure \
50 --with-apxs=%{apxs}
c9c87750
AM
51%{__make}
52
53%install
54rm -rf $RPM_BUILD_ROOT
55install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_sysconfdir}/conf.d}
456f9439 56install -d $RPM_BUILD_ROOT{/var/run/php-ug,%{systemdtmpfilesdir}}
c9c87750 57
ae0cdc1e 58install -p .libs/mpm_itk.so $RPM_BUILD_ROOT%{_pkglibdir}
10eb5784 59cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/10_mod_%{mod_name}.conf
82dde414 60cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/99_mod_%{mod_name}-php.conf
d1b80007 61cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/php-itk-dirs.conf
c9c87750
AM
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%post
67%service -q httpd restart
68
69%postun
70if [ "$1" = "0" ]; then
71 %service -q httpd restart
72fi
73
74%files
75%defattr(644,root,root,755)
76%doc CHANGES README
77%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
82dde414 78%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}-php.conf
c9c87750 79%attr(755,root,root) %{_pkglibdir}/mpm_itk.so
d1b80007 80%{systemdtmpfilesdir}/php-itk-dirs.conf
82dde414 81# multiple uid/gids in use
456f9439 82%dir %attr(1773,root,root) /var/run/php-ug
82dde414 83
This page took 0.148939 seconds and 4 git commands to generate.