]> git.pld-linux.org Git - packages/apache-mod_mime_xattr.git/blame - apache-mod_mime_xattr.spec
new, verison 0.4; builds with apache 2.4
[packages/apache-mod_mime_xattr.git] / apache-mod_mime_xattr.spec
CommitLineData
4e37a036
ER
1%define mod_name mime_xattr
2%define apxs %{_sbindir}/apxs
3Summary: Apache HTTPD module: mod_mime_xattr
4Name: apache-mod_%{mod_name}
5Version: 0.4
6Release: 1
7License: Apache v2.0
8Group: Networking/Daemons/HTTP
9Source0: http://0pointer.de/lennart/projects/mod_mime_xattr/mod_mime_xattr-%{version}.tar.gz
10# Source0-md5: cf04dd8d8ce31a9690f7ddc4495f1b3b
11Source1: apache.conf
12URL: http://0pointer.de/lennart/projects/mod_mime_xattr/
13BuildRequires: %{apxs}
14BuildRequires: apache-devel >= 2.2
15BuildRequires: autoconf >= 2.57
16BuildRequires: automake >= 1:1.9
17BuildRequires: rpmbuild(macros) >= 1.268
18Requires: apache(modules-api) = %apache_modules_api
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
22%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
23
24%description
25mod_mime_xattr is a module for the Apache HTTPD which may be used to
26set a range of MIME properties of files served from a document tree
27with extended attributes (EAs) as supported by the underlying file
28system.
29
30The current version of mod_mime_xattr has support for Linux style EAs
31which are supported by Linux 2.4 with the ACL/EA patches applied and
32vanilla Linux 2.6. The following attributes may be used:
33
34- user.mime_type: set the MIME type of a file explicitly. This
35 attribute is compatible with the shared MIME database specification as
36 published by freedesktop.org
37- user.charset: set the charset used in a file
38- user.mime_encoding: set the MIME encoding of a file (e.g. gzip)
39- user.apache_handler: set the apache handler of a file explicitly
40
41%prep
42%setup -q -n mod_%{mod_name}-%{version}
43
44%build
45%configure \
46 --with-apxs=%{apxs}
47%{__make}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
52install -p src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
53
54cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%post
60%service -q httpd restart
61
62%postun
63if [ "$1" = "0" ]; then
64 %service -q httpd restart
65fi
66
67%files
68%defattr(644,root,root,755)
69%doc README
70%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
71%attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
This page took 0.050385 seconds and 4 git commands to generate.